Ask Your Question
1

[ERROR] ./stack.sh:326 keystone did not start

asked 2013-04-05 21:03:20 -0500

jim-pherson gravatar image

Trying to setup the devstack environment in Ubuntu 12.04

Can't seem to get past this issue - it appears that this is a similar problem to 192113

  • screen -S stack -p key -X stuff 'cd /opt/stack/keystone && /opt/stack/keystone/bin/keystone-all --config-file /etc/keystone/keys'one.conf --log-config /etc/keystone/logging.conf -d --debug || touch "/opt/stack/status/stack/key.failure"
  • echo 'Waiting for keystone to start...' Waiting for keystone to start...
  • timeout 60 sh -c 'while ! http_proxy= curl -s http://10.2.13.125:5000/v2.0/ >/dev/null; do sleep 1; done'
  • die 326 'keystone did not start'
  • local exitcode=0
  • '[' 0 == 0 ']'
  • exitcode=1
  • set +o xtrace [ERROR] ./stack.sh:326 keystone did not start jpherson@ubuntu:~/Downloads/Openstack/devstack$ ps aux | grep keystone jpherson 4578 0.9 1.0 117044 42368 pts/2 S+ 13:47 0:01 python /opt/stack/keystone/bin/keystone-all --config-file /etc/keystone/keystone.conf --log-config /etc/keystone/logging.conf -d --debug jpherson 4587 0.0 0.0 8104 920 pts/0 S+ 13:49 0:00 grep --color=auto keystone jpherson@ubuntu:~/Downloads/Openstack/devstack$

jpherson@ubuntu:~/Downloads/Openstack/devstack$ cd /opt/stack/keystone && /opt/stack/keystone/bin/keystone-all --config-file /etc/keystone/keystone.conf --log-config /etc/keystone/logging.conf -d --debug (keystone-all): 2013-04-05 12:37:23,998 DEBUG cfg log_opt_values ************************* (keystone-all): 2013-04-05 12:37:23,998 DEBUG cfg log_opt_values Configuration options gathered from: (keystone-all): 2013-04-05 12:37:23,998 DEBUG cfg log_opt_values command line args: ['--config-file', '/etc/keystone/keystone.conf', '--log-config', '/etc/keystone/logging.conf', '-d', '--debug'] (keystone-all): 2013-04-05 12:37:23,999 DEBUG cfg log_opt_values config files: ['/etc/keystone/keystone.conf'] (keystone-all): 2013-04-05 12:37:23,999 DEBUG cfg log_opt_values ================================================================================ (keystone-all): 2013-04-05 12:37:23,999 DEBUG cfg log_opt_values admin_endpoint = http://localhost:%25(admin_port)d/ (http://localhost:%(admin_port)d/) (keystone-all): 2013-04-05 12:37:23,999 DEBUG cfg log_opt_values admin_port = 35357 (keystone-all): 2013-04-05 12:37:23,999 DEBUG cfg log_opt_values admin_token = password (keystone-all): 2013-04-05 12:37:24,000 DEBUG cfg log_opt_values auth_admin_prefix = (keystone-all): 2013-04-05 12:37:24,000 DEBUG cfg log_opt_values bind_host = 0.0.0.0 (keystone-all): 2013-04-05 12:37:24,000 DEBUG cfg log_opt_values compute_port = 8774 (keystone-all): 2013-04-05 12:37:24,000 DEBUG cfg log_opt_values config_dir = None (keystone-all): 2013-04-05 12:37:24,000 DEBUG cfg log_opt_values config_file = ['/etc/keystone/keystone.conf'] (keystone-all): 2013-04-05 12:37:24,001 DEBUG cfg log_opt_values crypt_strength = 40000 (keystone-all): 2013-04-05 12:37:24,001 DEBUG cfg log_opt_values debug = True (keystone-all): 2013-04-05 12:37:24,001 DEBUG cfg log_opt_values log_config = /etc/keystone/logging.conf (keystone-all): 2013-04-05 12:37:24,001 DEBUG cfg log_opt_values log_date_format = %Y-%m-%d %H:%M:%S (keystone-all): 2013-04-05 12:37:24,001 DEBUG cfg log_opt_values log_dir = None (keystone-all): 2013-04-05 12:37:24,001 DEBUG cfg log_opt_values log_file = None (keystone-all): 2013-04-05 12:37:24,002 DEBUG cfg log_opt_values log_format = %(asctime)s %(levelname)8s [%(name)s] %(message)s (keystone-all): 2013-04-05 12:37:24,002 DEBUG cfg log_opt_values max_param_size = 64 (keystone-all): 2013-04-05 12:37:24,002 DEBUG cfg log_opt_values max_request_body_size = 114688 (keystone-all): 2013-04-05 ... (more)

edit retag flag offensive close merge delete

11 answers

Sort by » oldest newest most voted
1

answered 2013-04-08 02:53:02 -0500

spzala gravatar image

Hi Jim, in the devstack root dir, where stack.sh is, you should see localrc file. One of the reason you see the 'keystone did not start' issue is due to wrong value of 'HOST_IP' in the localrc file or if you have set it in any other way. Make sure that that the value to HOST_IP is set to the correct ip address, if you haven't already tried it, and run the stack.sh again. I ran into this in past and this was the solution for my problem. Thanks!

edit flag offensive delete link more
0

answered 2013-10-09 14:19:44 -0500

where you changes following setting ? mean in which file?

Also set no_proxy="localhost,127.0.0.1,localaddress,.localdomain.com,<ip address="" of="" local="" machine="">"

edit flag offensive delete link more
0

answered 2013-05-03 20:50:03 -0500

jim-pherson gravatar image

Ok, there were several things that were changed at the same time. I found this web site helpful, but it did not fix the problem. http://www.stackgeek.com/blog/kordless/post/taking-openstack-for-a-spin (http://www.stackgeek.com/blog/kordles...) - but it might have moved me in the forward direction. Pay attention to setting up the localrc file. 1. If you are behind a proxy several things will not work depending if http_proxy, https_proxy, HTTP_PROXY, HTTPS_PROXY are all not set up and Acquire::http::Proxy "your proxy:8080/"; setup in your apt.conf file 2. Also set no_proxy="localhost,127.0.0.1,localaddress,.localdomain.com, " 3. There were firewalls that had to be shutdown 4. run visudo •Add the following line. •Defaults env_keep += "no_proxy http_proxy https_proxy HTTP_PROXY HTTPS_PROXY" 5. Add the stack user and run openstack as the stack user •sudo adduser stack •sudo apt-get install sudo -y •echo "stack ALL=(ALL) NOPASSWD: ALL" | sudo tee -a /etc/sudoers •sudo apt-get install git -y •login as stack user sudo su - stack and change the password passwd

I would say that 2, 4 or 5 were the most likely issues that I had.

Good Luck

edit flag offensive delete link more
0

answered 2013-05-02 23:17:05 -0500

tjones-i gravatar image

I have the same issue - what did you change that caused it to work?

on the console i have this

(eventlet.wsgi.server): 2013-05-02 16:06:04,911 DEBUG wsgi write (47964) wsgi starting up on http://0.0.0.0:35357/

(eventlet.wsgi.server): 2013-05-02 16:06:04,911 DEBUG wsgi write (47964) wsgi starting up on http://0.0.0.0:5000/

and it fails with this

2013-05-02 16:05:42 + timeout 60 sh -c 'while ! http_proxy= curl -s http://192.168.140.127:5000/v2.0/ >/dev/null; do sleep 1; done' 2013-05-02 16:06:37 + die 326 'keystone did not start'

edit flag offensive delete link more
0

answered 2013-04-09 11:00:28 -0500

(eventlet.wsgi.server): 2013-04-05 12:37:24,384 DEBUG wsgi write (6933) wsgi starting up on http://0.0.0.0:5000/

^C(root): 2013-04-05 12:48:30,978 DEBUG keystone-all sigint_handler SIGINT received, stopping servers.

Seems keystone was launched successfully from your shell.

run devstack/rejoin-stack.sh to attach back to the screen session and switch to keystone window to have a look at the console output. That would give you more clues.

edit flag offensive delete link more
0

answered 2013-04-08 17:00:18 -0500

jim-pherson gravatar image

Also, there is a proxy on the 10.2.13.125 address, don't know if that would cause an issue

edit flag offensive delete link more
0

answered 2013-04-08 16:37:57 -0500

jim-pherson gravatar image

I wish that were the case, but perhaps because I didn't understand some of the other variables in localrc, something else is interfering.
eth0 Link encap:Ethernet HWaddr 00:0c:29:5d:c9:41
inet addr:10.2.13.125 Bcast:10.2.255.255 Mask:255.255.0.0

HOST_IP=10.2.13.125 FLAT_INTERFACE=eth0 FIXED_RANGE=10.2.25.0/24 FIXED_NETWORK_SIZE=256 FLOATING_RANGE=10.2.13.224/27

I am setting this up on a VM, if I create another network say eth1 and use that exclusively for devstack since I don't control the 10.2.13.125 range.

edit flag offensive delete link more
0

answered 2013-04-09 22:45:36 -0500

jim-pherson gravatar image

I'm not sure all that you are suggesting, in the rejoin terminal it stops printing with the following

(eventlet.wsgi.server): 2013-04-09 15:37:57,783 DEBUG wsgi write (3310) wsgi starting up on http://0.0.0.0:35357/

(eventlet.wsgi.server): 2013-04-09 15:37:57,784 DEBUG wsgi write (3310) wsgi starting up on http://0.0.0.0:5000/

I am not sure when you say to "switch to keystone window to have a look at the console output" what I should be doing. I appreciate your help.

edit flag offensive delete link more
0

answered 2013-04-15 21:47:23 -0500

jim-pherson gravatar image

I believe that it was that localrc was not pointing to the right IP areas. I did something completely different and it worked, so it is not conclusive.

edit flag offensive delete link more
0

answered 2013-04-11 14:21:07 -0500

press CTRL + a + n to switch to the next window in your screen session each time util you reach "key" window

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-04-05 21:03:20 -0500

Seen: 2,856 times

Last updated: Oct 09 '13