Ask Your Question
0

multi-node compute: Determining IP information for eth0... failed

asked 2012-01-14 22:18:07 -0500

shh-han gravatar image

Hi All,

I have configured a two-node Ubuntu 11.04 based openstack diablo compute environment. Both nodes are running 11.04 server. The controller node has enabled all required nova services including nova-compute and nova-network, and the compute node is only running nova-compute.

For my experiment, I also created a customized CentOS 5.7 image at the controller's glance server.

So far from the controller node, running euca-run-instances command, I have no problem spawning instances onto the controller node. I am able to ssh into the spawned instance from the controller.

Now I disabled nova-compute on the controller node, and enabled nova-compute on the pure compute node. But after I started euca-run-instances from the controller, from the compute node's nova-compute.log, I found the instance was spawned successfully. For instance,

2012-01-14 14:35:08,588 INFO nova.virt.libvirt_conn [-] Instance instance-00000095 destroyed successfully.

However, I cannot ping the instance. After I checked the instance's console.log, I found its network was not started successfully at the booting time, and saw the error message,

Bringing up interface eth0: Determining IP information for eth0... failed. [FAILED]^M

I have tried hard on modifying both nova.conf and /etc/network/interfaces, but had no luck to fix the problem. So I desparately need your help based on the following configuration:

On the controller node, ospc001, I have nova.conf like this: root@ospc001:~/euca# cat /etc/nova/nova.conf --network_manager=nova.network.manager.FlatDHCPManager --flat_network_dhcp_start=192.168.0.2 --flat_network_bridge=br100 --public_interface=eth0 --flat_injected=False --use_ipv6=false --dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --force_dhcp_release=True --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --flagfile=/etc/nova/nova-compute.conf --use_deprecated_auth --verbose --my_ip=192.55.50.172 --network_host=ospc001 --s3_host=192.55.50.172 --rabbit_host=192.55.50.172 --cc_host=192.55.50.172 --ec2_url=http://192.55.50.172:8773/services/Cloud --s3_url=http://192.55.50.172:3333 --vncproxy_url=http://192.55.50.172:6080 --sql_connection=mysql://nova:notnova@192.55.50.172/nova --routing_source_ip=192.55.50.172 --glance_host=192.55.50.172 --glance_port=9292 --glance_api_servers=192.55.50.172:9292 --image_service=nova.image.glance.GlanceImageService --fixed_range=192.168.0.0/16 --network_size=8 --FAKE_subdomain=ec2 --iscsi_ip_prefix=192.168.0 --libvirt_type=kvm

root@ospc001:~/euca# ps -ef | grep dnsmasq nobody 6928 1 0 Jan12 ? 00:00:05 dnsmasq --strict-order --bind-interfaces --conf-file= --domain=novalocal --pid-file=/var/lib/nova/networks/nova-br100.pid --listen-address=192.168.0.1 --except-interface=lo --dhcp-range=192.168.0.2,static,120s --dhcp-lease-max=256 --dhcp-hostsfile=/var/lib/nova/networks/nova-br100.conf --dhcp-script=/usr/bin/nova-dhcpbridge --leasefile-ro root 6929 6928 0 Jan12 ? 00:00:04 dnsmasq --strict-order --bind-interfaces --conf-file= --domain=novalocal --pid-file=/var/lib/nova/networks/nova-br100.pid --listen-address=192.168.0.1 --except-interface=lo --dhcp-range=192.168.0.2,static,120s --dhcp-lease-max=256 --dhcp-hostsfile=/var/lib/nova/networks/nova-br100.conf --dhcp-script=/usr/bin/nova-dhcpbridge --leasefile-ro

On the controller node, I have network interface like this

root@ospc001:~/euca# cat /etc ... (more)

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2012-01-27 02:49:30 -0500

vishvananda gravatar image

nova will move the ip from eth0 to br100 when it creates it. So it actually works better without dhcp on eth0

On Jan 26, 2012, at 6:11 PM, josh wrote:

Question #184736 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Solved

josh confirmed that the question is solved: Thanks for reply. I solved my problem by reconfiguring br100 on the controller node. It was set on vnet0 (that was automatically set by nova), now I set it on eth1 which has no IP address but is connected to a local private switch. On the compute, I did the same thing. So VMs on the compute node can communicate with the controller nova-network via a matching pair of br100, and obtained valid private IP address.

What if I have only a single NIC on the controller and compute node? I know if eth0 is a dhcp interface, setting br100 on eth0 will work. But if eth0 is static interface, then setting br100 on eth0 won't work because their interfaces are conflicting to each other, one dhcp and one static.


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2012-01-14 23:37:14 -0500

shh-han gravatar image

On the controller node, I saw this bridge interface

root@ospc001:~/euca# brctl show bridge name bridge id STP enabled interfaces br100 8000.fe163e3e8dde no vnet0 vnet1 vnet2 vnet3 virbr0 8000.000000000000 yes

So br100 is sitting on vnet0, not sitting on eth1. Is it possible a root cause? In my case, eth1 does not have a valid IP as described below, so neither br100 and vnet0.

On the controller root@ospc001:~/euca# ip addr 1: lo: <loopback,up,lower_up> mtu 16436 qdisc noqueue state UNKNOWN link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo inet 169.254.169.254/32 scope link lo inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc mq state UP qlen 1000 link/ether 00:24:81:88:c0:76 brd ff:ff:ff:ff:ff:ff inet 192.55.50.172/24 brd 192.55.50.255 scope global eth0 inet 192.55.50.173/32 scope global eth0 inet6 fe80::224:81ff:fe88:c076/64 scope link valid_lft forever preferred_lft forever 3: eth1: <broadcast,multicast> mtu 1500 qdisc noop state DOWN qlen 1000 link/ether 00:24:81:88:c0:74 brd ff:ff:ff:ff:ff:ff 4: virbr0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether 02:eb:e4:dc:ca:02 brd ff:ff:ff:ff:ff:ff inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0 5: br100: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN link/ether fe:16:3e:3e:8d:de brd ff:ff:ff:ff:ff:ff inet 192.168.0.1/24 brd 192.168.0.255 scope global br100 inet6 fe80::48b2:55ff:feb2:e310/64 scope link valid_lft forever preferred_lft forever 8: vnet0: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 500 link/ether fe:16:3e:3e:8d:de brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fe3e:8dde/64 scope link valid_lft forever preferred_lft forever 29: vnet2: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 500 link/ether fe:16:3e:4f:ad:cf brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fe4f:adcf/64 scope link valid_lft forever preferred_lft forever 31: vnet1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 500 link/ether fe:16:3e:4a:ee:5d brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fe4a:ee5d/64 scope link valid_lft forever preferred_lft forever 32: vnet3: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 500 link/ether fe:16:3e:74:92:90 brd ff:ff:ff:ff:ff:ff inet6 fe80::fc16:3eff:fe74:9290/64 scope link valid_lft forever preferred_lft forever

But on the compute node, I saw this bridge interface root@ospc005:~# brctl show bridge name bridge ... (more)

edit flag offensive delete link more
0

answered 2012-01-25 15:32:43 -0500

zyluo gravatar image

You need the nova-compute, nova-network, and metadata-api to run together on multi-node mode. Tthe metadata ip has to be its ip in each nova.conf

edit flag offensive delete link more
0

answered 2012-01-27 02:07:57 -0500

shh-han gravatar image

Thanks for reply. I solved my problem by reconfiguring br100 on the controller node. It was set on vnet0 (that was automatically set by nova), now I set it on eth1 which has no IP address but is connected to a local private switch. On the compute, I did the same thing. So VMs on the compute node can communicate with the controller nova-network via a matching pair of br100, and obtained valid private IP address.

What if I have only a single NIC on the controller and compute node? I know if eth0 is a dhcp interface, setting br100 on eth0 will work. But if eth0 is static interface, then setting br100 on eth0 won't work because their interfaces are conflicting to each other, one dhcp and one static.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-01-14 22:18:07 -0500

Seen: 733 times

Last updated: Jan 27 '12