Ask Your Question
0

I can't get vnc console

asked 2011-04-18 10:49:45 -0500

rafadurancastaneda gravatar image

Hi,

I need some support in order to get VNC console from running instances. I'm using stack get_vnc_cosole:

stack --user=rafael --project=myproject compute get_vnc_console instance_id=4 {u'url': u'http://127.0.0.1:6080/vnc_auto.html?token=090929ea-f573-45e0-9efa-efe68b72af49&host=hostignore&port=portignore'}

Then I've tried the given url in both chrome and firefox, getting two different errors. In chrome I've got noVNC screen and a 'Server disconnected' error. In firefox I've also got noVNC screen but error message is now 'Connect timeout', in addition when firefox is used I get this output from command line:

localhost.localdomain - - [18/Apr/2011 12:41:48] code 400, message Bad request syntax ('<policy-file-request/>\x00') localhost.localdomain - - [18/Apr/2011 12:41:48] "<policy-file-request/>" 40

I'd appreciate some help a lot

edit retag flag offensive close merge delete

15 answers

Sort by » oldest newest most voted
0

answered 2011-04-19 00:41:13 -0500

vishvananda gravatar image

Are you running nova-vncproxy?

It has to be running for vnc console to work.

On Apr 18, 2011, at 3:49 AM, Rafael Durán Castañeda wrote:

New question #153266 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+q...

Hi,

I need some support in order to get VNC console from running instances. I'm using stack get_vnc_cosole:

stack --user=rafael --project=myproject compute get_vnc_console instance_id=4 {u'url': u'http://127.0.0.1:6080/vnc_auto.html?token=090929ea-f573-45e0-9efa-efe68b72af49&host=hostignore&port=portignore'}

Then I've tried the given url in both chrome and firefox, getting two different errors. In chrome I've got noVNC screen and a 'Server disconnected' error. In firefox I've also got noVNC screen but error message is now 'Connect timeout', in addition when firefox is used I get this output from command line:

localhost.localdomain - - [18/Apr/2011 12:41:48] code 400, message Bad request syntax ('<policy-file-request/>\x00') localhost.localdomain - - [18/Apr/2011 12:41:48] "<policy-file-request/>" 40

I'd appreciate some help a lot


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-04-26 09:28:35 -0500

rafadurancastaneda gravatar image

Ok, I will open a bug report

edit flag offensive delete link more
0

answered 2011-04-26 09:19:34 -0500

ethuleau gravatar image

Your welcome.

Could you open a ticket for that ?

Regards, Édouard.

edit flag offensive delete link more
0

answered 2011-04-26 09:17:13 -0500

rafadurancastaneda gravatar image

Thanks Edouard Thuleau, that solved my question.

edit flag offensive delete link more
0

answered 2011-04-19 07:35:23 -0500

rafadurancastaneda gravatar image

Yes I'm running nova-api, nova-compute, nova-network, nova-objestore, nova-scheduler, nova-direct-api and nova-vncproxy. Any other suggesstion?

Anyway thanks for your answer

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-04-18 10:49:45 -0500

Seen: 1,619 times

Last updated: Apr 27 '12