Ask Your Question
0

I can't get vnc console

asked 2011-04-18 10:49:45 -0500

rafadurancastaneda gravatar image

Hi,

I need some support in order to get VNC console from running instances. I'm using stack get_vnc_cosole:

stack --user=rafael --project=myproject compute get_vnc_console instance_id=4 {u'url': u'http://127.0.0.1:6080/vnc_auto.html?token=090929ea-f573-45e0-9efa-efe68b72af49&host=hostignore&port=portignore'}

Then I've tried the given url in both chrome and firefox, getting two different errors. In chrome I've got noVNC screen and a 'Server disconnected' error. In firefox I've also got noVNC screen but error message is now 'Connect timeout', in addition when firefox is used I get this output from command line:

localhost.localdomain - - [18/Apr/2011 12:41:48] code 400, message Bad request syntax ('<policy-file-request/>\x00') localhost.localdomain - - [18/Apr/2011 12:41:48] "<policy-file-request/>" 40

I'd appreciate some help a lot

edit retag flag offensive close merge delete

15 answers

Sort by » oldest newest most voted
0

answered 2011-04-19 00:41:13 -0500

vishvananda gravatar image

Are you running nova-vncproxy?

It has to be running for vnc console to work.

On Apr 18, 2011, at 3:49 AM, Rafael Durán Castañeda wrote:

New question #153266 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+q...

Hi,

I need some support in order to get VNC console from running instances. I'm using stack get_vnc_cosole:

stack --user=rafael --project=myproject compute get_vnc_console instance_id=4 {u'url': u'http://127.0.0.1:6080/vnc_auto.html?token=090929ea-f573-45e0-9efa-efe68b72af49&host=hostignore&port=portignore'}

Then I've tried the given url in both chrome and firefox, getting two different errors. In chrome I've got noVNC screen and a 'Server disconnected' error. In firefox I've also got noVNC screen but error message is now 'Connect timeout', in addition when firefox is used I get this output from command line:

localhost.localdomain - - [18/Apr/2011 12:41:48] code 400, message Bad request syntax ('<policy-file-request/>\x00') localhost.localdomain - - [18/Apr/2011 12:41:48] "<policy-file-request/>" 40

I'd appreciate some help a lot


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-04-19 07:35:23 -0500

rafadurancastaneda gravatar image

Yes I'm running nova-api, nova-compute, nova-network, nova-objestore, nova-scheduler, nova-direct-api and nova-vncproxy. Any other suggesstion?

Anyway thanks for your answer

edit flag offensive delete link more
0

answered 2011-04-19 14:06:35 -0500

vishvananda gravatar image

Do you also have the patched version of NoVNC?

I also recall having to set vncproxy_url to a public facing ip, although that may have just been because I didn't have a web browser on the machine that was running it.

Vish

On Apr 19, 2011, at 12:35 AM, Rafael Durán Castañeda wrote:

Question #153266 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Open

Rafael Durán Castañeda is still having a problem: Yes I'm running nova-api, nova-compute, nova-network, nova-objestore, nova-scheduler, nova-direct-api and nova-vncproxy. Any other suggesstion?

Anyway thanks for your answer


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-04-19 15:44:48 -0500

ethuleau gravatar image

I've got the same issue than Rafael. I set the flag vncproxy_url to a public IP for the same reasons of Vish. In chrome I've got noVNC screen and a 'Server disconnected' error.

I try to use it with libvirt/KVM with bzr1003.

edit flag offensive delete link more
0

answered 2011-04-19 18:48:23 -0500

rafadurancastaneda gravatar image

I'm using https://github.com/sleepsonthefloor/noVNC (https://github.com/sleepsonthefloor/n...) noVNC version, and I'm testing all in localhost. Do I need test from another computer? Any ohter suggestion?

edit flag offensive delete link more
0

answered 2011-04-19 19:10:49 -0500

Are you on a multi-server configuration? If so, how are your services organized across hosts? Also, just to double check, do your instance.host names resolve properly? and are your instances pingable?

There do appear to be issues with Firefox - noVNC switches to using a websocket emulation mode that uses adobe flash for the socket connection. The flash protocol aspects are not yet supported.

edit flag offensive delete link more
0

answered 2011-04-19 19:31:22 -0500

rafadurancastaneda gravatar image

I'm testing all on a single machine installation, I'll check again, but I haven't had any network problem so far. I can connect via ssh, using noVNC server directly, using others VNC clients,.. but I can't connect neither via chrome nor firefox using nova-vncproxy + noVNC.

Thanks for answering

edit flag offensive delete link more
0

answered 2011-04-19 21:29:08 -0500

You can check which port the actual vncserver is bound to by using 'virsh dumpxml.' Verify that you can curl that port (It will respond with an error, but that should tell you that the instance's vnc server is up and running).

The version of noVNC you are using should be fine, but the most recent one is here: git://github.com/openstack/noVNC.git

edit flag offensive delete link more
0

answered 2011-04-20 08:40:17 -0500

rafadurancastaneda gravatar image

As you told me I've checked running machines with virsh dumpxml. Virtual machines are using ports 5900 and 5901 as expected. When I tried curl http://127.0.0.1:5900/5901 I got: RFB 003.008. So that isn't the problem, it occurs only when I use nova-vncproxy, as I explain before I can get VNC console from noVNC server and any other VNC clients, only when I try to reach virtual machines via proxy I get error. In addition I noticed an error in vnc_auto.html when I'm using noVNC, nova-vncproxy and chrome. In my first attempt I didn't get noVNC screen and after inspect the given url (via chrome debugger) I got: Uncaught ReferenceError: token is not defined in window.onload: vnc_auto.html: 98. After this I changed vnc_auto.html:92

var host, port, password; --> var host, port, password, token;

After this I got noVNC scrren and sever disconnected error.

Any other suggestion?

edit flag offensive delete link more
0

answered 2011-04-20 13:11:38 -0500

ethuleau gravatar image

I solve the same problem on my installation (Nova bzr1003 on Ubuntu 10.04 LTS) by put the flag 'vnc_debug' to false (normally it's the default value but I set it to true the first time I try to use VNC proxy). I hope it's can help you and if the case, we should open a bug.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-04-18 10:49:45 -0500

Seen: 1,729 times

Last updated: Apr 27 '12