Ask Your Question
0

I can't get vnc console

asked 2011-04-18 10:49:45 -0500

rafadurancastaneda gravatar image

Hi,

I need some support in order to get VNC console from running instances. I'm using stack get_vnc_cosole:

stack --user=rafael --project=myproject compute get_vnc_console instance_id=4 {u'url': u'http://127.0.0.1:6080/vnc_auto.html?token=090929ea-f573-45e0-9efa-efe68b72af49&host=hostignore&port=portignore'}

Then I've tried the given url in both chrome and firefox, getting two different errors. In chrome I've got noVNC screen and a 'Server disconnected' error. In firefox I've also got noVNC screen but error message is now 'Connect timeout', in addition when firefox is used I get this output from command line:

localhost.localdomain - - [18/Apr/2011 12:41:48] code 400, message Bad request syntax ('<policy-file-request/>\x00') localhost.localdomain - - [18/Apr/2011 12:41:48] "<policy-file-request/>" 40

I'd appreciate some help a lot

edit retag flag offensive close merge delete

15 answers

Sort by ยป oldest newest most voted
0

answered 2011-04-19 21:29:08 -0500

You can check which port the actual vncserver is bound to by using 'virsh dumpxml.' Verify that you can curl that port (It will respond with an error, but that should tell you that the instance's vnc server is up and running).

The version of noVNC you are using should be fine, but the most recent one is here: git://github.com/openstack/noVNC.git

edit flag offensive delete link more
0

answered 2011-04-20 08:40:17 -0500

rafadurancastaneda gravatar image

As you told me I've checked running machines with virsh dumpxml. Virtual machines are using ports 5900 and 5901 as expected. When I tried curl http://127.0.0.1:5900/5901 I got: RFB 003.008. So that isn't the problem, it occurs only when I use nova-vncproxy, as I explain before I can get VNC console from noVNC server and any other VNC clients, only when I try to reach virtual machines via proxy I get error. In addition I noticed an error in vnc_auto.html when I'm using noVNC, nova-vncproxy and chrome. In my first attempt I didn't get noVNC screen and after inspect the given url (via chrome debugger) I got: Uncaught ReferenceError: token is not defined in window.onload: vnc_auto.html: 98. After this I changed vnc_auto.html:92

var host, port, password; --> var host, port, password, token;

After this I got noVNC scrren and sever disconnected error.

Any other suggestion?

edit flag offensive delete link more
0

answered 2011-04-20 13:11:38 -0500

ethuleau gravatar image

I solve the same problem on my installation (Nova bzr1003 on Ubuntu 10.04 LTS) by put the flag 'vnc_debug' to false (normally it's the default value but I set it to true the first time I try to use VNC proxy). I hope it's can help you and if the case, we should open a bug.

edit flag offensive delete link more
0

answered 2011-04-26 19:13:49 -0500

The flag vnc_debug is for protocol debugging. It bypasses authentication, and allows you to specify the vnc host and port in the url, thereby allowing you to connect to vnc consoles without asking for a token.

The vnc host and port is considered private, which is why the api doesn't return that information. Perhaps if the vnc_debug flag is set, we could embed the proper host/port info in the url so that it works by default.

edit flag offensive delete link more
0

answered 2012-04-27 03:51:22 -0500

zhonghuabaima0913 gravatar image

dear all, i have the same question.

i cannot connect the instance from dashboard. I have 11 machines to build the cloud.keystone,glance,dashboard,mysql and nova were installed on the controller(192.168.80.10/192.168.78.10) . And glance ,nova are also are installed other machines. my question is that nova-consoleauth is needed to install on every machine???

And nova-novncproxy is also needed to install on every machine???

That is the machine's (192.168.80.11/192.168.78.11)nova.conf

[DEFAULT] verbose=True auth_strategy=keystone allow_resize_to_same_host=True compute_scheduler_driver=nova.scheduler.filter_scheduler.FilterScheduler dhcpbridge_flagfile=/etc/nova/nova.conf fixed_range=10.0.3.0/24 flat_network_dhcp_start=10.0.3.2 s3_host=192.168.78.10 network_manager=nova.network.manager.FlatDHCPManager volume_group=nova-volumes volume_name_template=volume-%08x iscsi_helper=tgtadm iscsi_ip_prefix=192.168.80. osapi_compute_extension=nova.api.openstack.compute.contrib.standard_extensions my_ip=192.168.78.10 public_interface=eth0 flat_interface=eth0 floating_range=192.168.81.0/24 flat_network_bridge=br100 sql_connection=mysql://nova:nova@192.168.78.10/nova libvirt_type=kvm instance_name_template=instance-%08x novncproxy_base_url=http://192.168.80.10:6080/vnc_auto.html xvpvncproxy_base_url=http://192.168.80.10:6081/console vncserver_listen=192.168.80.10 vncserver_proxyclient_address=192.168.80.10 api_paste_config=/etc/nova/api-paste.ini image_service=nova.image.glance.GlanceImageService ec2_dmz_host=192.168.78.10 rabbit_host=192.168.78.10 rabbit_password=guest glance_api_servers=192.168.78.10:9292 force_dhcp_release=True connection_type=libvirt firewall_driver=nova.virt.libvirt.firewall.IptablesFirewallDriver logdir=/var/log/nova multi_host=true

and my /etc/init/nova-novncproxy.conf was wrote "exec /opt/stack/noVNC/utils/nova-novncproxy --config_file /etc/nova/nova.conf --web /opt/stack/noVNC -d --debug"

What is wrong with me ??? Thankyou!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-04-18 10:49:45 -0500

Seen: 1,731 times

Last updated: Apr 27 '12