Ask Your Question
0

quantum and openvswitch configuration

asked 2013-01-10 13:27:34 -0500

I have an installation of openstack-folsom with quantum and openvswitch. I have a controller (all the services, quantum server and openvswitch agent) and a compute (with openvswitch agent) On both nodes, I have br-int and br-eth2 (eth2 is the physical NIC with VLANs configured on it)... The ovs plugin ini contains:

tenant_network_type = vlan network_vlan_ranges = eth2:150:299 integration_bridge = br-int bridge_mappings = eth2:br-eth2

I have created a provider network, a subnet and two ports on this subnet like this:

quantum net-create net1 --tenant_id ... --provider:network_type vlan --provider:physical_network eth2 --provider:segmentation_id 150 quantum subnet-create --no-gateway net1 10.0.1.0/24 --enable_dhcp False quantum port-create --fixed-ip subnet_id=...,ip_address=10.0.1.100 net1

and finally spawn two virtual machine (one on the compute and the other on the controller) with the created ports. The two VMs are running but I cannot ping one VM from the other. The ping on one VM triggers ARP requests that arrive to the br-eth2 bridge on the physical host where the other VM is but they never reach the VM itself. The tcpdump on the eth1 interface of the destination VM shows no incoming traffic.

Is there something conceptually wrong?

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2013-01-14 16:59:38 -0500

Thanks yong sheng gong, that solved my question.

edit flag offensive delete link more
0

answered 2013-01-11 00:10:58 -0500

gongysh gravatar image

why do u have port IP at 10.0.1.100 with subnet 10.0.3.0/24? can u make sure your VM gets the wanted IP since you are not using DHCP agent?

edit flag offensive delete link more
0

answered 2013-01-11 10:49:00 -0500

I'm sorry...copy-paste error! I'm not using DHCP agent because I need VMs to have specific IP addresses. So I give the address to the VM's NIC manually. Anyway ping wasn't working because there was a mismatch between the ovs_plugin_ini for the controller and compute hosts. Now I am using two kind of provider networks: one is of type vlan (using br-eth2 and physical network eth2), the other is flat (using br0 and physical network eth3). br0 is another openvswitch with eth3 interface as a port.

ovs_plugin_ini contains:

tenant_network_type = vlan network_vlan_ranges = eth2:150:299,eth3 integration_bridge = br-int bridge_mappings = eth2:br-eth2,eth3:br-0

I created two networks in the same tenant because I want them to reflect existing physical networks in the data center: quantum net-create net1 --tenant_id ... --provider:network_type vlan --provider:physical_network eth2 --provider:segmentation_id 15 quantum net-create net2 --tenant_id ... --provider:network_type flat --provider:physical_network eth3

and two subnets quantum subnet-create --no-gateway net1 10.0.1.0/24 --enable_dhcp False quantum subnet-create --no-gateway net1 192.168.80.160/28 --enable_dhcp False

After spawning a new VM with two NICs on the above subnets, ping the VMs isn't working anymore. Is the fact that br0 has an IP address a problem? Or is the configuration of ovs_plugin wrong?

edit flag offensive delete link more
0

answered 2013-01-13 01:36:57 -0500

gongysh gravatar image

I don't think it is due to the IP address on br-0. You can try to boot two VMs on the same host with the same network, and then try to ping each other. If it works, you should check your physical networks. If the security group rule of nova is blocking the ICMP message? you can ran iptables-save on compute host to see if there are rules on VM's icmp traffic.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-01-10 13:27:34 -0500

Seen: 22 times

Last updated: Jan 14 '13