Problem connecting to Floodlight from Quantum

asked 2013-03-21 21:00:02 -0500

We are implementing a test lab environment with OpenStack pointing to a Floodlight controller on another computer. The Floodlight controller is working and responds when a third computer running Devstack sends it requests, such as Add Network.

When we attempt to add a network from the OpenStack computer, the network is added in the MySQL quantum database on the OpenStack system, but there is no activity that shows on the Floodlight controller and the network creation fails. No subnet is created, but an entry for the network appears in the dashboard. We would expect the OpenStack computer to work like the DevStack computer and create a network with a subnet.

Here is the quantum log from the OpenStack system showing the failure:

2013-03-21 11:55:59 DEBUG [keystone.middleware.auth_token] Authenticating user token 2013-03-21 11:55:59 DEBUG [keystone.middleware.auth_token] Removing headers from request environment: X-Identity-Status,X-Tenant-Id,X-Tenant-Name,X-User-Id,X-User-Name,X-Roles,X-Service-Catalog,X-User,X-Tenant,X-Role 2013-03-21 11:55:59 DEBUG [routes.middleware] No route matched for POST /networks.json 2013-03-21 11:55:59 DEBUG [routes.middleware] Matched POST /networks.json 2013-03-21 11:55:59 DEBUG [routes.middleware] Route path: '/networks{.format}', defaults: {'action': u'create', 'controller': wsgify(quantum.api.v2.resource.resource, RequestClass=<class 'quantum.api.v2.resource.request'="">)} 2013-03-21 11:55:59 DEBUG [routes.middleware] Match dict: {'action': u'create', 'controller': wsgify(quantum.api.v2.resource.resource, RequestClass=<class 'quantum.api.v2.resource.request'="">), 'format': u'json'} 2013-03-21 11:55:59 DEBUG [quantum.openstack.common.rpc.amqp] Sending network.create.start on notifications.info 2013-03-21 11:55:59 DEBUG [amqplib] Closed channel #1 2013-03-21 11:55:59 DEBUG [amqplib] using channel_id: 1 2013-03-21 11:55:59 DEBUG [amqplib] Channel open 2013-03-21 11:55:59 DEBUG [quantum.openstack.common.rpc.amqp] Sending network.create.start on notifications.info 2013-03-21 11:55:59 DEBUG [amqplib] Closed channel #1 2013-03-21 11:55:59 DEBUG [amqplib] using channel_id: 1 2013-03-21 11:55:59 DEBUG [amqplib] Channel open 2013-03-21 11:55:59 DEBUG [quantum.plugins.bigswitch.plugin] QuantumRestProxyV2: create_network() called 2013-03-21 11:55:59 DEBUG [quantum.plugins.bigswitch.common.lockutils] Got semaphore "rest_call" for method "rest_call"... 2013-03-21 11:55:59 DEBUG [quantum.plugins.bigswitch.common.lockutils] Attempting to grab file lock "rest_call" for method "rest_call"... 2013-03-21 11:55:59 DEBUG [quantum.plugins.bigswitch.common.lockutils] Released file lock "rest_call" at /usr/lib/python2.7/dist-packages/quantum/plugins/bigswitch/bsn-rest_call for method "rest_call"... 2013-03-21 11:55:59 ERROR [quantum.api.v2.resource] create failed Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/quantum/api/v2/resource.py", line 96, in resource result = method(request=request, *args) File "/usr/lib/python2.7/dist-packages/quantum/api/v2/base.py", line 335, in create obj = obj_creator(request.context, *kwargs) File "/usr/lib/python2.7/dist-packages/quantum/plugins/bigswitch/plugin.py", line 359, in create_network ret = self.servers.post(resource, data) File "/usr/lib/python2.7/dist-packages/quantum/plugins/bigswitch/plugin.py", line 250, in post return self.rest_call('POST', resource, data, headers) File "/usr ... (more)

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-03-21 22:33:28 -0500

THANK YOU!! Yes, that did fix the problem.

I will follow the link to set the problem to solved.

Mike Tisdale

-----Original Message----- From: bounces@canonical.com [mailto:bounces@canonical.com] On Behalf Of Sumit Naiksatam Sent: Thursday, March 21, 2013 3:16 PM To: Tisdale, MichaelX J Subject: Re: [Question #224859]: Problem connecting to Floodlight from Quantum

Your question #224859 on quantum changed: https://answers.launchpad.net/quantum/+question/224859 (https://answers.launchpad.net/quantum...)

Status: Open => Answered

Sumit Naiksatam proposed the following answer: Hi, I believe your non-devstack installation is using packages. In that case it's missing the lock_path configuration in quantum.conf configuration file. You need to set this to some directory to which the owner of the quantum server process can write to.

Try setting the following in the [DEFAULT] section:

lock_path = /run/lock/quantum


If this answers your question, please go to the following page to let us know that it is solved: https://answers.launchpad.net/quantum/+question/224859/+confirm?answer_id=0 (https://answers.launchpad.net/quantum...)

If you still need help, you can reply to this email or go to the following page to enter your feedback: https://answers.launchpad.net/quantum/+question/224859 (https://answers.launchpad.net/quantum...)

You received this question notification because you asked the question.

edit flag offensive delete link more
0

answered 2013-03-21 22:16:03 -0500

Hi, I believe your non-devstack installation is using packages. In that case it's missing the lock_path configuration in quantum.conf configuration file. You need to set this to some directory to which the owner of the quantum server process can write to.

Try setting the following in the [DEFAULT] section:

lock_path = /run/lock/quantum

edit flag offensive delete link more
0

answered 2013-03-21 22:34:17 -0500

Yes, thank you very much, that fixed the problem.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-03-21 21:00:02 -0500

Seen: 50 times

Last updated: Mar 21 '13