Ask Your Question
0

Can't SSH into VMs on compute nodes

asked 2012-08-10 11:04:06 -0500

msekni gravatar image

Hi all, i have installed OpenStack on 7 nodes : 1 Controller node : Nova-* / keystone/glance/ horizon 6 compute nodes : nova-network, nova-volume and nova-compute Fixed Network : 10.0.0.0/20 Floating Network: 157.159.100.33/20 Evrything seems fine but when i launch a vm on a compute node, i can't SSH into it. Port 22 is already open and working but after i do this : ssh -i priv_key ubuntu@157.159.100.33 , it asks me for a password for the ubuntu login !! i tried a lot of other images ( cirros, tty linux, ..) but still the same result. Note that injection of key to VM is done flawlessly check : http://pastebin.com/TPxsk8UP Note also that i can access to my VMs using their Fixed IPs instead of the floating ones ! Note that SNAT / DNAT seems good

I have installed OpenStack on a single Node, used the same images and it worked like a charm, so to narrow this down, is there an extra configuration i should for my compute node ?

PLEASE HELP, I HAVE TO DO A DEMO for my boss very Soon , Thanks

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2012-09-10 02:15:11 -0500

wonder-zou gravatar image

what is the OS ? 64bit or 32 bit, you can not ssh to a 64bit image, in 32bit host.

edit flag offensive delete link more
0

answered 2012-08-10 11:48:18 -0500

tomasz-michal-klosinski gravatar image

You have to add a rule to the security group to open port 22.

You may do this in dashboard - in Access and Security -> Secuirty Groups -> Edit rules:

IP Protocol: TCP From Port: 22 To Port: 22 Secure Group: CIDR CIDR: 0.0.0.0/0

edit flag offensive delete link more
0

answered 2012-08-10 11:48:54 -0500

tomasz-michal-klosinski gravatar image

http://docs.openstack.org/essex/openstack-compute/admin/content/enabling-ping-and-ssh-on-vms.html (http://docs.openstack.org/essex/opens...)

edit flag offensive delete link more
0

answered 2012-08-10 13:37:22 -0500

msekni gravatar image

@Tomasz

Thanks for replying but i already said Port 22 is Open and well set in my security rule. It's not a port issue, the VM is not recognizing the private key :(

edit flag offensive delete link more
0

answered 2012-08-15 09:28:55 -0500

you're using cirros images, and what is the image says is...

login as 'cirros' user. default password: 'cubswin:)'. use 'sudo' for root.

does this make sense?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-08-10 11:04:06 -0500

Seen: 133 times

Last updated: Sep 10 '12