Ask Your Question
0

Instance State is "Networking"

asked 2011-09-01 01:41:02 -0500

naangilsunder gravatar image

Hi ,

I have Installed Nova in my local environment successfully. All my nova services are running.

My problem is while I try to launch Instance am getting the status of my Instance as “networking“ …

The Output of /nova-compute.log

2011-09-01 01:37:02,618 INFO nova.virt.libvirt_conn [-] Compute_service record updated for nova 2011-09-01 01:37:02,625 DEBUG nova.rpc [-] Initing the Adapter Consumer for compute from (pid=4973) __init__ /usr/lib/pymodules/python2.6/nova/rpc.py:148 2011-09-01 01:37:02,667 DEBUG nova.rpc [-] Initing the Adapter Consumer for compute.nova from (pid=4973) __init__ /usr/lib/pymodules/python2.6/nova/rpc.py:148 2011-09-01 01:37:02,703 INFO nova.rpc [-] Created 'compute_fanout' fanout exchange with 'compute' routing key 2011-09-01 01:37:02,704 DEBUG nova.rpc [-] Initing the Adapter Consumer for compute from (pid=4973) __init__ /usr/lib/pymodules/python2.6/nova/rpc.py:148 2011-09-01 01:37:05,664 DEBUG nova.rpc [-] received {u'_context_request_id': u'2U4L-H10YL0DG0R7VFWI', u'_context_read_deleted': False, u'args': {u'instance_id': 9, u'injected_files': None, u'availability_zone': None}, u'_context_is_admin': True, u'_context_timestamp': u'2011-09-01T01:37:05Z', u'_context_user': u'novaadmin', u'method': u'run_instance', u'_context_project': u'proj', u'_context_remote_address': u'172.16.1.12'} from (pid=4973) _receive /usr/lib/pymodules/python2.6/nova/rpc.py:167 2011-09-01 01:37:05,665 DEBUG nova.rpc [-] unpacked context: {'timestamp': u'2011-09-01T01:37:05Z', 'remote_address': u'172.16.1.12', 'project': u'proj', 'is_admin': True, 'user': u'novaadmin', 'request_id': u'2U4L-H10YL0DG0R7VFWI', 'read_deleted': False} from (pid=4973) _unpack_context /usr/lib/pymodules/python2.6/nova/rpc.py:331 2011-09-01 01:37:05,700 AUDIT nova.compute.manager [2U4L-H10YL0DG0R7VFWI novaadmin proj] instance 9: starting... 2011-09-01 01:37:05,785 DEBUG nova.rpc [-] Making asynchronous call on network ... from (pid=4973) call /usr/lib/pymodules/python2.6/nova/rpc.py:350 2011-09-01 01:37:05,785 DEBUG nova.rpc [-] MSG_ID is b63bd88ffc2c45f195994e96d5193666 from (pid=4973) call /usr/lib/pymodules/python2.6/nova/rpc.py:353

Nova.conf

--dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --lock_path=/var/lock/nova --state_path=/var/lib/nova --verbose --s3_host=172.16.1.12 --rabbit_host=172.16.1.12 --cc_host=172.16.1.12 --ec2_url=http://172.16.1.12:8773/services/Cloud --fixed_range=192.168.3.0/25 --network_size=8 --FAKE_subdomain=ec2 --routing_source_ip=172.16.1.12 --sql_connection=mysql://root:root@172.16.1.12/nova --glance_host=172.16.1.12 --image_service=nova.image.glance.GlanceImageService --network_manager=nova.network.manager.FlatDHCPManager --flat_network_dhcp_start=192.168.3.3 --public_interface=eth0:1 --flat_injected=False --flat_interface=eth0

Network Config

The primary network interface

auto eth0 iface eth0 inet static address 172.16.1.12 netmask 255.255.255.0 #broadcast 172.16.1.1255 gateway 172.16.1.1

auto eth0:1 iface eth0:1 inet static address 172.16.1.52 netmask 255.255.255.0 #broadcast 172.16.1.1255 gateway 172.16.1.1

please Help

edit retag flag offensive close merge delete

9 answers

Sort by » oldest newest most voted
0

answered 2011-09-01 02:20:44 -0500

blamar gravatar image

Can you provide the contents of your nova-network.log? http://paste.openstack.org

edit flag offensive delete link more
0

answered 2011-09-01 17:40:53 -0500

naangilsunder gravatar image

virsh,

after i restart the nova-network,i get the log of netwok as in the link http://paste.openstack.org/show/2340/

edit flag offensive delete link more
0

answered 2011-09-02 00:41:06 -0500

naangilsunder gravatar image

hi,

all service are running as root users .also tried as per the link, still getting the Instance status as "Networking"

please help...........

edit flag offensive delete link more
0

answered 2011-09-05 22:38:40 -0500

naangilsunder gravatar image

Hi,

I reinstalled the setup and its working now tks for every one :)

edit flag offensive delete link more
0

answered 2011-09-01 20:05:44 -0500

blamar gravatar image

It looks like you might need to set up the user which is running nova-network to have sudoers access. Normally this is done by having a file like /etc/sudoers.d/nova_sudoers which looks like this: http://paste.openstack.org/show/2348/

edit flag offensive delete link more
0

answered 2011-09-01 02:38:51 -0500

naangilsunder gravatar image

hi , Thanks for your reply

The output of nova.network.log http://paste.openstack.org/show/2330/

edit flag offensive delete link more
0

answered 2011-09-01 05:02:08 -0500

vishvananda gravatar image

looks like you have a ghost lock file. Try clearing out /var/lock/nova/ and restart nova-network.

On Aug 31, 2011, at 7:41 PM, naangilsunder wrote:

Question #169750 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Needs information => Open

naangilsunder gave more information on the question: hi , Thanks for your reply

The output of nova.network.log http://paste.openstack.org/show/2330/


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-09-01 17:22:18 -0500

naangilsunder gravatar image

hi virsh,

i cleared out /var/lock/nova/ and tried restart nova-network but still am getting the status of instance as "Networking".

Please help .....

edit flag offensive delete link more
0

answered 2011-09-01 17:30:34 -0500

vishvananda gravatar image

Do you still see it waiting on lock? If so, perhaps it is using a different lock directory: maybe try --lock_path=/tmp

On Sep 1, 2011, at 10:25 AM, naangilsunder wrote:

Question #169750 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Open

naangilsunder is still having a problem: hi virsh,

i cleared out /var/lock/nova/ and tried restart nova-network but still am getting the status of instance as "Networking".

Please help .....


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-09-01 01:41:02 -0500

Seen: 120 times

Last updated: Sep 05 '11