Ask Your Question
0

swift error logs and error: [Errno 111] ECONNREFUSED

asked 2011-09-28 09:21:04 -0500

moeketsi-christopher gravatar image

Hello ,I was wondering if any one could help me with this problem .I have installed a multimode installation based on the steps provided by http://swift.openstack.org/howto_installmultinode.html (http://swift.openstack.org/howto_inst...) . The only difference that I made to the installation was that all my storage nodes have single hard drives and so I have partition the hard drives to ext3 for ubuntu and xfs for swift. The xfs partion is mounted at /svr/node/sdb1 on all the node.

every time I run swift -A https://<proxy_ip>:8080/auth/v1.0 -U system:root -K testpass stat

i get [Errno 111] ECONNREFUSED and when I run swift -A https://<proxy_ip>:8080/auth/v1.0 -U system:root -K <mypass> upload myfiles openSUSE-11.4-DVD-i586.iso where <proxy_ip> is the proxy ip address and <my_pass> is the password I get this error.

File "/usr/bin/swift", line 949, in run self.func(item, self.args, *self.kwargs) File "/usr/bin/swift", line 1639, in _object_job headers = conn.head_object(container, obj) File "/usr/bin/swift", line 861, in head_object return self._retry(None, head_object, container, obj) File "/usr/bin/swift", line 792, in _retry rv = func(self.url, self.token, args, *kwargs) File "/usr/bin/swift", line 573, in head_object conn.request('HEAD', path, '', {'X-Auth-Token': token}) File "/usr/lib/python2.7/httplib.py", line 955, in request self._send_request(method, url, body, headers) File "/usr/lib/python2.7/httplib.py", line 989, in _send_request self.endheaders(body) File "/usr/lib/python2.7/httplib.py", line 951, in endheaders self._send_output(message_body) File "/usr/lib/python2.7/httplib.py", line 811, in _send_output self.send(msg) File "/usr/lib/python2.7/httplib.py", line 773, in send self.connect() File "/usr/lib/python2.7/httplib.py", line 1154, in connect self.timeout, self.source_address) File "/usr/lib/pymodules/python2.7/eventlet/green/socket.py", line 59, in create_connection raise error, msg error: [Errno 111] ECONNREFUSED I also can not find the log files for swift.

I also don't know where the log files are.

my proxy-server.conf file is as follows

[DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift log_facility = LOG_LOCAL1

[pipeline:main] pipeline = healthcheck cache tempauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:tempauth] use = egg:swift#tempauth user_system_root = testpass .admin https://<proxy_ip>/v1/AUTH_system

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = <proxy_ip>:11211

I also get this when I enter the code below curl -k -v -H 'X-Auth-Token: AUTH_****' https:// <proxy_ip>:8080/v1/AUTH_system

  • About to connect() to <proxy_ip> port 8080 (#0)
  • Trying 1 connected
  • Connected to <proxy_ip> ( <proxy_ip>) port 8080 (#0)
  • successfully set certificate verify locations:
  • CAfile: none CApath: /etc/ssl/certs
  • SSLv3, TLS handshake, Client hello (1):
  • SSLv3, TLS handshake, Server hello (2):
  • SSLv3, TLS handshake, CERT (11):
  • SSLv3, TLS handshake, Server finished (14):
  • SSLv3, TLS handshake, Client key exchange (16):
  • SSLv3, TLS change cipher, Client ...
(more)
edit retag flag offensive close merge delete

7 answers

Sort by ยป oldest newest most voted
0

answered 2011-09-28 09:36:49 -0500

moeketsi-christopher gravatar image

I ahve read the other posts on a similar error , but it does not help

edit flag offensive delete link more
0

answered 2011-10-04 10:29:19 -0500

moeketsi-christopher gravatar image

Thanks Christophe Le Guern, that solved my question.

edit flag offensive delete link more
0

answered 2011-10-04 10:31:48 -0500

moeketsi-christopher gravatar image

Thank a lot Christophe! I got another error after that ... managed to get around though. But Your solution solved the initial problem.

edit flag offensive delete link more
0

answered 2011-09-29 18:50:18 -0500

c35sys gravatar image

It seems your certificate is incorrect, since I saw this in your logs: * common name: christopher (does not match ' <proxy_ip>')

Your certificate should have your IP as a common name.

edit flag offensive delete link more
0

answered 2012-01-09 06:31:07 -0500

I'm facing the same issue on my AIO testing environment.

But I don't see any info including "common name" after I typed "curl -k -v -H 'X-Auth-Token: AUTH_****' https:// <proxy_ip>:8080/v1/AUTH_system".

Can you please tell me what is going on? :(

edit flag offensive delete link more
0

answered 2012-01-09 06:32:59 -0500

I'm sorry, the command I typed should be "curl -k -v -H 'X-Auth-Token: AUTH_****' https:// 127.0.0.1:8080/v1/AUTH_test"

edit flag offensive delete link more
0

answered 2013-06-20 04:00:16 -0500

juck78 gravatar image

if you config is right, please chick out the hardware to make sure they were mounted!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-09-28 09:21:04 -0500

Seen: 102 times

Last updated: Jun 20 '13