Can't start nova-volume

asked 2011-02-22 03:35:50 -0600

Hi everyone,

I can't start up the nova-volume . I can't see the service when i use nova-manage service list.This about the nova-volume.log and nova.conf inoformation.

nova-volume.log

2011-02-22 11:14:07,359 AUDIT nova.root [-] Starting volume node (version 2011.1-workspace:tarmac-20110202111800-10sib5zxlu8xluca) 2011-02-22 11:14:07,359 DEBUG nova.root [-] Serving nova-volume from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:224 2011-02-22 11:14:07,359 DEBUG nova.root [-] Full set of FLAGS: from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:225 2011-02-22 11:14:07,360 DEBUG nova.root [-] rabbit_retry_interval : 10 from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,360 DEBUG nova.root [-] volume_topic : volume from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,360 DEBUG nova.root [-] region_list : [] from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,360 DEBUG nova.root [-] help : None from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,360 DEBUG nova.root [-] ec2_dmz_host : 192.168.30.117 from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,360 DEBUG nova.root [-] volume_name_template : volume-%08x from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,361 DEBUG nova.root [-] compute_topic : compute from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,361 DEBUG nova.root [-] default_instance_type : m1.small from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,361 DEBUG nova.root [-] glance_port : 9292 from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,361 DEBUG nova.root [-] rabbit_password : guest from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,361 DEBUG nova.root [-] network_manager : nova.network.manager.FlatManager from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,361 DEBUG nova.root [-] default_log_levels : ['amqplib=WARN', 'sqlalchemy=WARN', 'eventlet.wsgi.server=WARN'] from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,361 DEBUG nova.root [-] s3_dmz : 192.168.30.117 from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,362 DEBUG nova.root [-] osapi_host : 192.168.30.117 from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,362 DEBUG nova.root [-] vpn_key_suffix : -vpn from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py:228 2011-02-22 11:14:07,362 DEBUG nova.root [-] scheduler_topic : scheduler from MainProcess (pid=4023) serve /usr/lib/pymodules/python2.6/nova/service.py ... (more)

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2011-02-23 02:30:43 -0600

guanxiaohua2k6 gravatar image

Add the following line with command "sudo visudo"

nova ALL=(ALL) NOPASSWD:ALL

Please see 1.2 of http://wiki.openstack.org/NovaInstall/NovaDeploymentTool (http://wiki.openstack.org/NovaInstall...) for detail info.

edit flag offensive delete link more
0

answered 2011-02-23 06:24:06 -0600

Thanks Christian Berendt, that solved my question.

edit flag offensive delete link more
0

answered 2011-02-23 14:12:04 -0600

You can also check and see if "#includedir /etc/sudoers.d" is present in /etc/sudoers.

edit flag offensive delete link more
0

answered 2011-02-22 06:40:35 -0600

berendt gravatar image

your error is: sudo: no tty present and no askpass program specified (google it, it's a well known problem)

also you have to create a volume group "nova-volumes" if you want to use nova-volume with the default configuration.

edit flag offensive delete link more
0

answered 2011-02-23 06:23:11 -0600

Thanks All !! I can fix this problem.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-02-22 03:35:50 -0600

Seen: 47 times

Last updated: Feb 23 '11