Ask Your Question
0

I can't spawn an instance in Compute node

asked 2012-12-11 11:48:27 -0600

tgsasi gravatar image

Hi Team,

I can't Spawn an instance in Compute node and i couldn't see any error in /var/log/nova/nova-compute.log. But i can able to create instance from Cloud controller.

Server 1 - Cloud Controller Server 2 - Compute node


T.G.Sasikumar

edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2012-12-16 04:49:04 -0600

Can I see the full log on http://paste.openstack.org/ ? Maybe you need to restart libvirtd.

edit flag offensive delete link more
0

answered 2012-12-17 09:19:30 -0600

tgsasi gravatar image

Hi Jian ,

I commented vnc configuration in /etc/nova/nova.conf in both cloud controller and compute node, Now i am able to create instance in compute node. Thanks for all your help.

Now i am facing network routing issue.

T.G.Sasikumar

edit flag offensive delete link more
0

answered 2012-12-11 14:08:03 -0600

tgsasi gravatar image

Hi Rajesh,

thanks for replying , I can create instance in cloud controller but not in compute node. I tried restarting RabbitMQ and all nova service. but no luck.


T.G.Sasikumar

edit flag offensive delete link more
0

answered 2012-12-11 12:11:00 -0600

rajeshkannan007 gravatar image

Hi Sasikumar,

This problem is arrised because of RabbitMQ, i think..

Restart RabbitMQ service and

Restart all nova services

Then check it...

let me know its working or not..

Regards, Rajesh kannan

edit flag offensive delete link more
0

answered 2012-12-12 09:45:26 -0600

To run in mulit-host mode, each compute host must run the following services: nova-compute, nova-network, nova-api-metadata or nova-api

Reference: http://docs.openstack.org/folsom/openstack-compute/admin/content/existing-ha-networking-options.html (http://docs.openstack.org/folsom/open...)

edit flag offensive delete link more
0

answered 2012-12-15 09:31:12 -0600

tgsasi gravatar image

Thanks Jian , but still instance is not spawning in Compute node , I have started the above said service but its not creating instance. In mysql i can see the below error message .

mysql -uroot -p

use nova;

select * from instance_faults;

instance_uuid: 603e82b9-9147-4208-a89d-217af0fb5a96 code: 500 message: libvirtError details: Unable to read from monitor: Connection reset by peer

File "/usr/lib/python2.7/dist-packages/libvirt.py", line 581, in createWithFlags if ret == -1: raise libvirtError ('virDomainCreateWithFlags() failed', dom=self)

Note : This compute node have single Network interface eth0 , So ihave changed in /etc/nova/nova.conf file in compute node is --flat_interface=eth0


T.G.Sasikumar

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-12-11 11:48:27 -0600

Seen: 68 times

Last updated: Dec 17 '12