Ask Your Question
0

quantum openvswitch plugin problem

asked 2013-05-22 15:32:33 -0500

Hi,

I've been searching a sollution for the error: ERROR [quantum.plugins.openvswitch.agent.ovs_quantum_agent] Failed to create OVS patch port. Cannot have tunneling enabled on this agent, since this version of OVS does not support tunnels or patch ports. Agent terminated!

but I get the impression that most of the people who has this problem is using Ubuntu 12.10.

My setup is 1 network node + 2 compute nodes. This problem is only present in one of the compute nodes, the other one seems to be fine. I'm using the same configuration in both compute nodes.

Can anyone help?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-04 04:22:56 -0500

Try this:

apt-get remove linux-headers* linux-image* apt-get install linux-headers-3.2.0-52-generic linux-image-3.2.0-52-generic apt-get install sudo apt-get install openvswitch-datapath-dkms

And restart your network node and compute nodes.

edit flag offensive delete link more
0

answered 2013-06-05 03:45:21 -0500

What version of ovs do you use? Can you manually add patch port with the ovs-vsctl?

edit flag offensive delete link more
0

answered 2013-05-23 09:12:09 -0500

gongysh gravatar image

to create a patch port, we need kernel module to support it. maybe you have upgraded your kernel version, in this case, we have to reinstall the openvswitch data path package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-22 15:32:33 -0500

Seen: 17 times

Last updated: Sep 04 '13