Ask Your Question
0

qemu: linux kernel too old to load a ram disk

asked 2011-09-28 14:41:45 -0500

islamsh gravatar image

I am testing diablo setup with two nodes. Previously these two nodes worked with cactus (both with natty and centos image, although for centos image I had to do this: https://answers.launchpad.net/nova/+question/167348 (https://answers.launchpad.net/nova/+q...)

compute node:

uname -ra

Linux i47 2.6.32-131.4.1.el6.x86_64 #1 SMP Fri Jun 10 10:54:26 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

euca-describe-instances say the vm is running but:

euca-get-console-output i-0000000f

i-0000000f 2011-09-28T14:34:14Z

Detail log is here: http://paste.openstack.org/show/2594/

This is with a natty image:

cat nova-compute.log |grep instance-0000000f

2011-09-28 10:25:47,002 nova.virt.libvirt_conn: instance instance-0000000f: Creating image 2011-09-28 10:25:47,064 nova.virt.libvirt_conn: instance instance-0000000f: injecting key into image 2 2011-09-28 10:25:52,754 nova.virt.libvirt_conn: instance instance-0000000f: ignoring error injecting data into image 2 (GuestFS instance has no attribute 'write_append') 2011-09-28 10:25:55,267 nova.virt.libvirt_conn: Instance instance-0000000f spawned successfully. 2011-09-28 10:27:14,425 nova.virt.libvirt_conn: Contents of file /var/lib/nova/instances/instance-0000000f/console.log: '' 2011-09-28 10:34:14,758 nova.virt.libvirt_conn: Contents of file /var/lib/nova/instances/instance-0000000f/console.log: ''

I also tried to run a centos image but it is stuck in pending. Is this a RHEL issue?

--sharif

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2011-09-28 16:08:30 -0500

islamsh gravatar image

Edier,

Thanks for confirming the error. For me, it works in the controller:

ssh -i sharif_natty_cc.pem ubuntu@xx.xx.xx.xxx. .

Welcome to Ubuntu 11.04 (GNU/Linux 2.6.38-11-virtual x86_64)

  • Documentation: https://help.ubuntu.com/

    System information as of Wed Sep 28 16:07:09 UTC 2011

    System load: 0.03 Processes: 63 Usage of /: 40.1% of 1.35GB Users logged in: 0 Memory usage: 6% IP address for eth0: 10.0.0.15 Swap usage: 0%

Graph this data and manage this system at https://landscape.canonical.com/

At the moment, only the core of the system is installed. To tune the system to your needs, you can choose to install one or more
predefined collections of software by running the following
command:

sudo tasksel --section server

Get cloud support with Ubuntu Advantage Cloud Guest http://www.ubuntu.com/business/services/cloud (http://www.ubuntu.com/business/servic...)

The programs included with the Ubuntu system are free software; the exact distribution terms for each program are described in the individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by applicable law.

To run a command as administrator (user "root"), use "sudo <command>". See "man sudo_root" for details.

ubuntu@server-21:~$

edit flag offensive delete link more
0

answered 2011-09-28 15:32:17 -0500

Hi Sharif, no it's not a RHEL issue, I just got same error in an Ubuntu 10.10 server system (I reinstall it yesterday because I was using Glance trunk (2011.3dev) and Nova Cactus and due to that (I think) My compute nodes didn't get the disk images, but the instances run perfectly in the Cloud Controller, today images are delivered to all the nodes perfectly but instances don't start, no matter if I run them in the Cloud Controller or Compute nodes :( Let's way some one give us a light about this. If I find how to fix it in my system I'll post it here.

Bye

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-09-28 14:41:45 -0500

Seen: 2,044 times

Last updated: Sep 28 '11