Ask Your Question
0

VM can't talk to metadata service in multi-node install

asked 2011-06-15 17:47:49 -0500

heckj gravatar image

Nova compute node is trying to access the metadata service on 169.254.169.254, and is unable to get there. It's a mutinode installation, and the node is receiving "connection refused", but the metadata service appears to be running.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2011-06-15 17:58:21 -0500

heckj gravatar image

Oops - correct IP address that it calls out to is: 169.254.169.254

edit flag offensive delete link more
0

answered 2011-06-15 17:49:14 -0500

heckj gravatar image

The VM calls out to 168.254.169.254 for meta data. The nova-api service is ready to answer, but it only talks on :8773. It is nova-network's job to set up a NAT in its iptables to route all 169.254.169.254 traffic to the nova-api instance. My nova-network was sending the traffic to itself and not to the nova-api machine.

The correct flag to use is to set --ec2_dmz_host to the address of the nova-api service, otherwise it defaults to the address of the nova-network machine.

edit flag offensive delete link more
0

answered 2011-06-15 17:49:38 -0500

heckj gravatar image

The VM calls out to 168.254.169.254 for meta data. The nova-api service is ready to answer, but it only talks on :8773. It is nova-network's job to set up a NAT in its iptables to route all 169.254.169.254 traffic to the nova-api instance. My nova-network was sending the traffic to itself and not to the nova-api machine.

The correct flag to use is to set --ec2_dmz_host to the address of the nova-api service, otherwise it defaults to the address of the nova-network machine.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-06-15 17:47:49 -0500

Seen: 67 times

Last updated: Jun 15 '11