How can I connect to Ubuntu Image using putty?

asked 2013-06-07 09:15:57 -0600

henrik16 gravatar image

updated 2013-06-07 09:19:38 -0600

Hi, I'm trying to connect to my instance with floating IP from putty but when I try to connect I do not have the key so, anyone knows how to setup this correctly ?

Thank you!

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-04-07 07:02:09 -0600

David Heijkamp gravatar image

updated 2014-04-09 03:13:53 -0600

smaffulli gravatar image

People who're struggling with this as well might benefit from this howto, describing the whole process: Howto: Creating and using OpenStack SSH keypairs on Windows

edit flag offensive delete link more
1

answered 2014-04-07 23:18:22 -0600

dbaxps gravatar image

updated 2014-04-08 00:31:22 -0600

If I would create instance via command (not the best option for sure, but working with no problems)

[root@dfw02 ~(keystone_boris)]$  nova boot --flavor 2 --user-data=./myfile.txt  
--image 03c9ad20-b0a3-4b71-aa08-2728ecb66210 UbuntuTRS01

where

[root@dfw02 ~(keystone_boris)]$  cat ./myfile.txt
#cloud-config
password: mysecret
chpasswd: { expire: False }
ssh_pwauth: True

Same is possible via Post Creation Tab's Customization Script Window in Dashboard. Ubuntu ( or any other instance ) . Instance won't require keypair at all.

Just  ssh ubuntu@compute-node will login you with password "mysecret"

Mentioned earlier Howto for Windows looks more attractive , so I post it just in case any problems with Howto for Windows.

edit flag offensive delete link more
0

answered 2013-06-07 09:24:19 -0600

Sagar Ratnakara Nikam gravatar image

When you launched the instance, you need to specify the keypair. Use that key to ssh to your instance. Without the key, you will not be able to SSH to the instance.

Also open port 22 in the security group for that VM. Port 22 is required for SSH access

edit flag offensive delete link more

Comments

I've done that.. my question is how to setup putty or console connection from ubuntu... Look at what I've done... From ubuntu , I downloaded the keypair (the one that is atached to vm) and after that I run this command: "ssh ubuntu@192.168.0.100 -i keypair.pem " but I got an error saying connection

henrik16 gravatar imagehenrik16 ( 2013-06-07 10:06:50 -0600 )edit

refused...

henrik16 gravatar imagehenrik16 ( 2013-06-07 10:07:01 -0600 )edit

Help?

henrik16 gravatar imagehenrik16 ( 2013-06-11 06:28:56 -0600 )edit

what happens with 'ssh -i keypair.pem 192.168.0.100' command

digitaldolby2002 gravatar imagedigitaldolby2002 ( 2013-06-28 00:11:12 -0600 )edit

@henrik16 edit your original question to make it clearer if you haven't found an answer yet. Comments are hard to read.

smaffulli gravatar imagesmaffulli ( 2014-04-09 03:15:32 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-06-07 09:15:57 -0600

Seen: 1,610 times

Last updated: Apr 09 '14