Ask Your Question
0

can anybody help me in installing devstack

asked 2013-06-07 02:50:44 -0600

pragya jain gravatar image

updated 2014-01-18 21:50:28 -0600

larsks gravatar image

I had installed Ubuntu 12.10 on my PC and Following the steps given on the site http://devstack.org/guides/single-machine.html but I get the following error:

root@anita:~#  cd devstack
root@anita:~/devstack# ./stack.sh
You are running this script as root.
In 10 seconds, we will create a user 'stack' and run as that user
Giving stack user passwordless sudo privileges
Copying files to stack user
cp: cannot create directory `/opt/stack/devstack': No such file or directory
chown: cannot access `/opt/stack/devstack': No such file or directory
./stack.sh: line 205: cd: /opt/stack/devstack: No such file or directory
bash: /root/.bash_profile: Permission denied
stack.sh: line 28: /root/devstack/functions: Permission denied
stack.sh: line 33: GetDistro: command not found
stack.sh: line 98: log_error: command not found
stack.sh: line 100: /root/devstack/stackrc: Permission denied
stack.sh: line 107: export_proxy_variables: command not found
stack.sh: line 125: log_error: command not found
stack.sh: line 131: log_error: command not found
stack.sh: line 135: /root/devstack/lib/database: Permission denied
stack.sh: line 136: /root/devstack/lib/rpc_backend: Permission denied
stack.sh: line 141: disable_negated_services: command not found
WARNING: this script has not been tested on 
stack.sh: line 148: die: command not found
stack.sh: line 154: check_rpc_backend: command not found
stack.sh: line 166: trueorfalse: command not found
stack.sh: line 214: is_package_installed: command not found
stack.sh: line 214: die: command not found
sudo: parse error in /etc/sudoers.d/50_stack_sh near line 1
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin
sudo: parse error in /etc/sudoers.d/50_stack_sh near line 1
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin
sudo: parse error in /etc/sudoers.d/50_stack_sh near line 1
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin
stack.sh: line 239: check_path_perm_sanity: command not found
stack.sh: line 244: trueorfalse: command not found
stack.sh: line 249: trueorfalse: command not found
sudo: parse error in /etc/sudoers.d/50_stack_sh near line 1
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin
sudo: parse error in /etc/sudoers.d/50_stack_sh near line 1
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin
stack.sh: line 269: get_default_host_ip: command not found
stack.sh: line 271: die: command not found
stack.sh: line 281: trueorfalse: command not found
stack.sh: line 290: trueorfalse: command not found
stack.sh: line 300: /root/devstack/lib/tls: Permission denied
stack.sh: line 301: /root/devstack/lib/horizon: Permission denied
stack.sh: line 302: /root/devstack/lib/keystone: Permission denied
stack.sh: line 303: /root/devstack/lib/glance: Permission denied
stack.sh: line 304: /root/devstack/lib/nova: Permission denied
stack.sh: line 305: /root/devstack/lib/cinder: Permission denied
stack.sh: line 306: /root/devstack/lib/swift: Permission denied
stack.sh: line 307: /root/devstack/lib/ceilometer: Permission ...
(more)
edit retag flag offensive close merge delete

10 answers

Sort by ยป oldest newest most voted
0

answered 2015-10-01 10:30:27 -0600

soppliger gravatar image

I had the same problem and traced it to an issue within the local.conf file I was using. I had copied a sample local.conf file that erroneously pointed to a log file using the path /opt/devstack. However, stack.sh creates its files in the path /opt/stack NOT /opt/devstack. Once I edited the log file path in the local.conf file by changing the path to /opt/stack, the installation worked perfectly.

edit flag offensive delete link more
0

answered 2015-10-09 13:42:30 -0600

On Ubuntu ensure that below file is deleted /etc/sudoers.d/50_stack_sh

Go to line number 202 which is

202 sudo mv $TEMPFILE /etc/sudoers.d/50_stack_sh

comment it and run your stack.sh . It shall work file .

edit flag offensive delete link more
0

answered 2016-06-01 19:56:10 -0600

Line 124 in script mysql in ../devstack/lib/database needs to have $HOME set. I solved this by adding the line: export HOME=/opt/stack near the top of the stack.sh script

edit flag offensive delete link more
0

answered 2016-02-11 00:23:53 -0600

socfreak390 gravatar image

I guess you are running ./stack.sh as root/superuser Can you try the following?

adduser stack
sudo visudo

Find the part of the file that is labeled "User privilege specification" and change it to the following

# User privilege specification
root    ALL=(ALL:ALL) ALL
stack   ALL=(ALL:ALL) ALL

Close the file, exit and log in as "stack". Download devstack and create /opt/stack

cd /home/stack
git clone https://github.com/openstack-dev/devstack -b stable/liberty
sudo mkdir /opt/stack

Create your local.conf file under /home/stack/devstack and give the following permissions.

sudo chown -R stack:stack /home/stack/devstack
sudo chown -R stack:stack /opt/stack
sudo chmod 770 /home/stack/devstack
sudo chmod 770 /opt/stack

then run ./stack.sh

edit flag offensive delete link more

Comments

I am getting the same error. When I give the permissions that you just mentioned above I get "stack is not in the sudoers file. This incident will be reported." Could you help me with this?

chaithanya gravatar imagechaithanya ( 2016-10-16 01:17:41 -0600 )edit

Here, stack is my username

chaithanya gravatar imagechaithanya ( 2016-10-16 01:20:47 -0600 )edit
0

answered 2014-01-19 00:07:01 -0600

amit kumar gravatar image

give me ur mail i will send GUIDE LINE

edit flag offensive delete link more

Comments

Can you send me also

satish.vaishnav gravatar imagesatish.vaishnav ( 2015-01-30 14:11:17 -0600 )edit
0

answered 2014-01-18 08:05:19 -0600

romeo gravatar image

updated 2014-01-18 21:49:46 -0600

larsks gravatar image

http://devstack.org/guides/single-machine.html is not a complete guide even contains many mistakes

for example: DevStack includes a sample in devstack/samples/local.conf

in the https://github.com/openstack-dev/devstack.git local.conf not exist

there are other files: local.sh Fix spelling mistakes 7 months ago localrc Updates samples/localrc comment

edit flag offensive delete link more
0

answered 2014-01-21 17:59:51 -0600

dtx gravatar image

Usually the permission denied error are due to wrong user.

  • Make sure that your stack.sh has the right permissions.
  • Make sure that your devstack dir belongs to the user you are executing as: sudo chown -R user:group /path/to/devstack
edit flag offensive delete link more
0

answered 2013-06-07 09:31:04 -0600

Sagar Ratnakara Nikam gravatar image

This looks like a permission problem on stack.sh. You can give the required permission using chmod.

Another option is to create a user and then do git clone of devstack and run stack.sh

stack.sh does not run in root user. If executed from root user, it creates a new user called stack and proceeds.

In your error, the stack user does not seem to have permission to run stack.sh

edit flag offensive delete link more

Comments

thanks for the suggestion I have installed ubuntu 12.10 64 bit AMD on my machine. In the terminal after reaching the root , i have created a user STACK using the following command : adduser stack after that ...the control shifts to the user stack

next i run the following command

pragya jain gravatar imagepragya jain ( 2013-06-08 04:35:47 -0600 )edit

apt-get install sudo -y echo "stack ALL=(ALL) NOPASSWD: ALL" >> /etc/sudoers after this command , there is no response and i get the next command prompt

then i perform the following commands:

sudo apt-get install git -y git clone git://github.com/openstack-dev/devstack.git cd devstack

pragya jain gravatar imagepragya jain ( 2013-06-12 01:02:31 -0600 )edit

after this the control shifts to devstack.Now when i run the command ./stack.sh

it shows that all Openstack components are disabled. The guide that I follow to install devstack http://devstack.org/guides/single-machine.html says that

pragya jain gravatar imagepragya jain ( 2013-06-12 01:02:56 -0600 )edit

to configure stack.sh. DevStack includes a sample in devstack/samples/localrc. Create localrc as shown below to do the following:

Set FLOATING_RANGE to a range not used on the local network, i.e. 192.168.1.224/27. This configures IP addresses ending in 225-254 to be used as floating IPs.

pragya jain gravatar imagepragya jain ( 2013-06-12 01:06:54 -0600 )edit

to configure stack.sh. DevStack includes a sample in devstack/samples/localrc. set some parameters and passwords in localrc file.i am also not able to set the passwords in the localrc file.

Can you please guide on how to handle this issue and how can i set the passwords in the localrc file?

pragya jain gravatar imagepragya jain ( 2013-06-12 01:23:27 -0600 )edit

I generally create a new user ex- "sagar" in my case, login to ubuntu using "sagar", then sudo apt-get install git

Sagar Ratnakara Nikam gravatar imageSagar Ratnakara Nikam ( 2013-06-12 11:24:39 -0600 )edit

cd devstack, then add the following to localrc

Sagar Ratnakara Nikam gravatar imageSagar Ratnakara Nikam ( 2013-06-12 11:27:19 -0600 )edit

echo ADMIN_PASSWORD=password > localrc echo MYSQL_PASSWORD=password >> localrc echo RABBIT_PASSWORD=password >> localrc echo SERVICE_PASSWORD=password >> localrc echo SERVICE_TOKEN=tokentoken >> localrc. Check this link http://devstack.org/guides/single-vm.html,

Sagar Ratnakara Nikam gravatar imageSagar Ratnakara Nikam ( 2013-06-12 11:27:32 -0600 )edit

finally run stack.sh, and openstack will be up once the script completes

Sagar Ratnakara Nikam gravatar imageSagar Ratnakara Nikam ( 2013-06-12 11:29:02 -0600 )edit
0

answered 2015-02-12 01:16:21 -0600

madhu_CC gravatar image

the user stack created using the script was mapping the user "stack"'s home path to /opt/stack. copied the devstack folder to /opt/stack and was able torun the stack.sh successfully.

edit flag offensive delete link more
0

answered 2015-06-08 08:19:40 -0600

In my case, i change permission to 777 on /opt/devstack fodler and run the script. It gave me some module missing errors, i downloaded modules from https://devpi.net/root/pypi/+simple/ and installed manually.

This worked for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-07 02:50:44 -0600

Seen: 23,026 times

Last updated: Feb 11 '16