nova failing to install (nova.rc template missing)

asked 2010-12-07 19:58:17 -0500

dirakx gravatar image

I've tested nova installation with relative success, bu i cannot create a project.

when i issue this

sudo nova-manage project zipfile myproject ttx

nova complains about a missing template and throws an error

sudo nova-manage project zipfile ORFEO rafael Traceback (most recent call last): File "/usr/local/bin/nova-manage", line 5, in <module> pkg_resources.run_script('nova==2011.1', 'nova-manage') File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 467, in run_script self.require(requires)[0].run_script(script_name, ns) File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1200, in run_script execfile(script_filename, namespace, namespace) File "/usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg/EGG-INFO/scripts/nova-manage", line 508, in <module> main() File "/usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg/EGG-INFO/scripts/nova-manage", line 500, in main fn(*argv) File "/usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg/EGG-INFO/scripts/nova-manage", line 362, in zipfile zip_file = self.manager.get_credentials(user_id, project_id) File "/usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg/nova/auth/manager.py", line 634, in get_credentials rc = self.__generate_rc(user.access, user.secret, pid) File "/usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg/nova/auth/manager.py", line 681, in __generate_rc rc = open(FLAGS.credentials_template).read() IOError: [Errno 2] No such file or directory: '/usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg/nova/auth/novarc.template'

I'm testing with nova's latest branch..how can i workaround this error ?

edit retag flag offensive close merge delete

7 answers

Sort by » oldest newest most voted
0

answered 2010-12-07 20:54:19 -0500

soren gravatar image

How exactly did you install nova? Which OS are you on?


Soren Hansen Ubuntu Developer    http://www.ubuntu.com/ OpenStack Developer http://www.openstack.org/

edit flag offensive delete link more
0

answered 2010-12-07 21:01:51 -0500

dirakx gravatar image

Hi Soren

I followed nova's quickstart guide and i'm in ubuntu 10.10.

edit flag offensive delete link more
0

answered 2010-12-07 21:05:37 -0500

soren gravatar image

Can you please be specific about what steps you took to install it? Copy and paste from the referenced guide if you want.


Soren Hansen Ubuntu Developer    http://www.ubuntu.com/ OpenStack Developer http://www.openstack.org/

edit flag offensive delete link more
0

answered 2010-12-07 21:19:26 -0500

dirakx gravatar image

I did something like the following

bzr clone lp:nova

./nova.sh branch ./nova.sh install ./nova.sh run

also i've checked and installed latest packages for ubuntu like this

$ sudo apt-get install python-software-properties $ sudo add-apt-repository ppa:nova-core/trunk $ sudo apt-get update

$ sudo apt-get install rabbitmq-server nova-api nova-objectstore nova-compute nova-scheduler nova-network euca2ools unzip

then while trying to do a project i got the aforementioned error.

after doing something like

$sudo nova-manage user admin user $sudo nova-manage project create myproject user $ sudo nova-manage project zipfile myproject user

edit flag offensive delete link more
0

answered 2010-12-07 21:22:05 -0500

vishvananda gravatar image

You appear to have an old release of nova which is interfering with the system. I suggest you remove /usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg then you should run nova-mangage from the bin dir in the nova folder that was created by nova.sh

Vish

On Dec 7, 2010, at 1:19 PM, dirakx wrote:

Question #136966 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

dirakx posted a new comment: I did something like the following

bzr clone lp:nova

./nova.sh branch ./nova.sh install ./nova.sh run

also i've checked and installed latest packages for ubuntu like this

$ sudo apt-get install python-software-properties $ sudo add-apt-repository ppa:nova-core/trunk $ sudo apt-get update

$ sudo apt-get install rabbitmq-server nova-api nova-objectstore nova-compute nova-scheduler nova-network euca2ools unzip

then while trying to do a project i got the aforementioned error.

after doing something like

$sudo nova-manage user admin user $sudo nova-manage project create myproject user $ sudo nova-manage project zipfile myproject user


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2010-12-07 21:45:36 -0500

dirakx gravatar image

I rm the

/usr/local/lib/python2.6/dist-packages/nova-2011.1-py2.6.egg

and it seems to work now, besides from the openssl config error.

but this is documented

''If you see an "error loading the config file './openssl.cnf'" it means you can copy the openssl.cnf file to the location where Nova expects it and reboot, then try the command again.

cp /etc/ssl/openssl.cnf ~ sudo reboot''

a las where should i put this cnf file in order to nova find it ?

Thanks soren and Vish for your kind replies

edit flag offensive delete link more
0

answered 2010-12-10 16:31:38 -0500

dirakx gravatar image

Thanks Vish Ishaya, that solved my question.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2010-12-07 19:58:17 -0500

Seen: 74 times

Last updated: Dec 10 '10