Ask Your Question
0

quantum/ovs not working after reboot of the host

asked 2012-06-03 23:25:40 -0500

vijayrg gravatar image

I was able to successfully install quantum and openvswitch (Essex version) . I was able to launch an instance and I was able to ping/ssh the instance through private ip as well as floating ip. However, after rebooting the system, I am not able to ping or ssh through private ip. In the instance console output, I see that it is not getting an ip leased (though nova list shows a private ip given to that instance). In /var/log/syslog, I see that dnsmasq-dhcp[1221]: DHCP packet received on gw-6e103f99-87 which has no address

Any clue is appreciated.

Thanks, -vj

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2012-06-05 05:29:57 -0500

danwent gravatar image

I suspect this is the same issue as: https://bugs.launchpad.net/nova/+bug/977759 (https://bugs.launchpad.net/nova/+bug/...)

This was fixed in a Folsom patch, and seems to have been backports to stable/essex: https://review.openstack.org/#/c/7267/

So I guess the question is whether the essex code you're running on is based on essex stable, and if so, whether the packages are new enough to have this change.

Perhaps you could manually patch the code to test if this is the issue?

edit flag offensive delete link more
0

answered 2012-07-20 03:40:18 -0500

guestly gravatar image

I have a similar problem. But my version is new enough, and after reboot the host, the dnsmasq service is start also. But the problem still exist! Here is my problem link: https://answers.launchpad.net/quantum/+question/203474 (https://answers.launchpad.net/quantum...)

edit flag offensive delete link more
0

answered 2012-06-04 17:06:54 -0500

danwent gravatar image

Somik, is this an issue that has been fixed but perhaps needs to be back-ported to essex stable?

Including Gary b/c of possible impact on essex stable.

edit flag offensive delete link more
0

answered 2012-06-04 02:19:40 -0500

gongysh gravatar image

Can you run the "ovs-vsctl show" and "ifconfig" and put the results here after reboot?

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-06-03 23:25:40 -0500

Seen: 33 times

Last updated: Jul 20 '12