Ask Your Question
1

Keystone and policy management not working correctly

asked 2013-06-06 07:46:57 -0600

foexle gravatar image

updated 2013-06-06 07:49:41 -0600

Hiho guys,

here is the third place where i ask my question :)

So no double postings or whatever, please take a look on my post: link:https://lists.launchpad.net/openstack/msg24196.html (Mailing list)

There's an exact descritption of my problem.

Futhermore i've tried to change the order of the rules and i've created a new rule:

"kadmin_required":[["role:KeystoneAdmin"]],
"admin_or_kadmin": [["rule:kadmin_required"], ["rule:admin_required"]],

I get everytime the same issue ... so no authorized and keystone check every time the rule "admin_required". Thats so strange.

Do anyone have an idea?

Thx and Greetings Heiko

edit retag flag offensive close merge delete

Comments

Did u get answer for this question? I am also trying something very similar

Sudheesh gravatar imageSudheesh ( 2013-08-07 05:51:53 -0600 )edit

@foexle Were you able to fix this one?

koolhead17 gravatar imagekoolhead17 ( 2013-08-13 07:02:38 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-08-13 07:07:38 -0600

foexle gravatar image

updated 2013-08-13 07:08:32 -0600

Heyho guys,

yeah sry :) it's not possible in grizzly release. This feature is fully supported in havana and you can't use it in grizzly correctly. Maybe with a mix of grizzly and havanna but not tested and i wouldn't advise to do.

Cheers Heiko

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-06-06 07:46:57 -0600

Seen: 105 times

Last updated: Aug 13 '13