Ask Your Question
0

Can't ping or ssh an instance on anything but control node

asked 2012-08-02 13:05:16 -0500

I have been trying to set up a multi-node OpenStack cloud network for some time now, and I keep hitting this one stumbling block.

I get the control node up, running all the OpenStack services, and I can deploy an instance and ssh into it. If I add a compute node, an instance that gets created there I can't ssh or ping.

I've included the two nova.conf files, along with the interfaces files. Please help, this is driving me insane.

To keep it simple, here's a description of a base configuration that exhibits this:

Control node - two nics (eth0 and eth1) running keystone/glance/nova-*/mysql

Compute node - two nics (eth0 and eth1) running nova-compute, nova-network, mysql-client, postresql-client

eth0 is on a public LAN, with a fixed address in both cases (192.168.1.14 and 192.168.1.15)

eth1 is connected to a private ethernet switch (Cisco)


Controller

nova.conf

--dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --allow_admin_api=true --use_deprecated_auth=false --auth_strategy=keystone --scheduler_driver=nova.scheduler.simple.SimpleScheduler --s3_host=192.168.1.14 --ec2_host=192.168.1.14 --rabbit_host=192.168.1.14 --cc_host=192.168.1.14 --nova_url=http://192.168.1.14:8774/v1.1/ --routing_source_ip=192.168.1.14 --glance_api_servers=192.168.1.14:9292 --image_service=nova.image.glance.GlanceImageService --iscsi_ip_prefix=172.31.252 --sql_connection=mysql://nova:openstack@192.168.1.14/nova --ec2_url=http://192.168.1.14:8773/services/Cloud --keystone_ec2_url=http://192.168.1.14:5000/v2.0/ec2tokens --api_paste_config=/etc/nova/api-paste.ini --libvirt_type=kvm --libvirt_use_virtio_for_bridges=true --start_guests_on_host_boot=true --resume_guests_state_on_host_boot=true --vnc_enabled=true --vncproxy_url=http:/192.168.1.14:6080 --vnc_console_proxy_url=http://192.168.1.14:6080

network specific settings

--network_manager=nova.network.manager.FlatDHCPManager --public_interface=eth0 --flat_interface=eth1 --flat_network_bridge=br100 --fixed_range=172.31.252.32/23 #--floating_range=128.163.188.240/27 #--auto_assign_floating_ip=True --network_size=500 --flat_network_dhcp_start=172.31.252.10 --flat_injected=False --force_dhcp_release --iscsi_helper=tgtadm --connection_type=libvirt --root_helper=sudo nova-rootwrap --verbose --max_cores=250


/etc/network/interfaces

This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo iface lo inet loopback

The primary network interface

auto eth0 iface eth0 inet static address 192.168.1.14 netmask 255.255.255.0 broadcast 192.168.1.255 network 192.168.1.0 gateway 192.168.1.1 dns-nameservers 192.168.1.1

auto br100 iface br100 inet static bridge_ports eth1 bridge_stp off bridge_maxwait 0 bridge_fd 0 address 172.31.252.1 netmask 255.255.254.0


Compute Node

nova.conf

--dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --allow_admin_api=true --use_deprecated_auth=false --auth_strategy=keystone --scheduler_driver=nova.scheduler.simple.SimpleScheduler --s3_host=192.168.1.14 --ec2_host=192.168.1.14 --rabbit_host=192.168.1.14 --cc_host=192.168.1.14 --nova_url=http://192.168.1.14:8774/v1.1/ --routing_source_ip=192.168.1.14 ...

(more)
edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2012-08-06 22:08:27 -0500

jaypipes gravatar image

What are the rules for the security group that you start the instances with?

edit flag offensive delete link more
0

answered 2012-08-07 19:53:23 -0500

jaypipes gravatar image

Looks like this was solved with multi_host=True... please close if so.

edit flag offensive delete link more
0

answered 2012-08-07 07:23:39 -0500

Hi Jay

They are:

TCP 22 22 0.0.0.0/0 ICMP -1 -1 0.0.0.0/0

edit flag offensive delete link more
0

answered 2013-01-28 16:45:53 -0500

sukpon3 gravatar image

Please share your solution in this problem. I have the same problem too and i stick it for a week. T T PS. base on https://answers.launchpad.net/nova/+question/220156 (https://answers.launchpad.net/nova/+q...)

edit flag offensive delete link more
0

answered 2013-01-29 08:43:58 -0500

Thanks Jay Pipes, that solved my question.

edit flag offensive delete link more
0

answered 2013-01-29 08:44:51 -0500

This was down to multi_host not being set in the nova config.

Dave

On 28 Jan 2013, at 16:50, sakpon question204852@answers.launchpad.net wrote:

Your question #204852 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+question/204852 (https://answers.launchpad.net/nova/+q...)

sakpon requested more information: Please share your solution in this problem. I have the same problem too and i stick it for a week. T T PS. base on https://answers.launchpad.net/nova/+question/220156 (https://answers.launchpad.net/nova/+q...)


To answer this request for more information, you can either reply to this email or enter your reply at the following page: https://answers.launchpad.net/nova/+question/204852 (https://answers.launchpad.net/nova/+q...)

You received this question notification because you asked the question.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-08-02 13:05:16 -0500

Seen: 95 times

Last updated: Jan 29 '13