Ask Your Question
0

Inter VM communication in multi-host VLAN networking

asked 2012-03-23 07:12:29 -0500

nilanjan-r gravatar image

I am using a two node nova installation-- I am using diablo release of openstack. Once node is the controller and it runs all the nova services. Another node is the compute node which runs nova-compute and nova-network service. I am using VLAN mode networking. I have created the private network with --multi-host=T and added the below flags in the /etc/nova/nova.conf file of both the servers.(Both the server are having 2 NIC cards and one we are using for VLAN ointerface and the other for public interface)

--multi_host=T --ec2_dmz_host=<public ip="" of="" the="" controller="" node=""> Created a project and associated the private network with it. Please note that my switch support host managed VLAN tagging and I have created the necessary trunking configuration in the switch. Spawning of instances works fine and instances are getting created on both controller and compute nodes.As we are using multi-host mode the compute node bridge is also getting an IP address. I am able to reach the instances from the controller and compute nodes. I am able to associate public IPs to the instances and reach the instances using the public IPs. Also inter communication between VMs using the public IP is working fine.

Now my problem is those instances that are running on compute node can't reach the privaye IP of the instances running on controller node, all the instances are on same VLAN. But the instances running on controller node can reach the private IP of the instances running on the compute node.

Now I disassociated the public IP from the instance running on compute node and connect to the private IP of the instance. Surprisingly it can reach the private IP of the instances running on controller node. If I associate the public IP again, then again the private IP of controller node instances become unreachable. Really weird!

It will be really helpful if somebody can throw light on this issue.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2012-03-23 12:19:14 -0500

nilanjan-r gravatar image

I got the solution to thsi problem. Actually I need to define --fixed_range flag in nova.conf file in all the nodes running nova-network. Setting this flag and restarting nova-network service in all the nodes has solved the issue.

I hope this might be useful to others.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-03-23 07:12:29 -0500

Seen: 121 times

Last updated: Mar 23 '12