Ask Your Question
0

incorrect result when executed glance index with keystone

asked 2012-04-11 09:48:57 -0500

s-rain gravatar image

Hello all,

I try to use glance with remote keystone, but the following incorrect result is occurred when I executed glance index with keystone. Please help me out.

Failed to show index. Got error: An object with the specified identifier was not found. Details: 404 Not Found

The resource could not be found.

glance-api log: /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req

root@glance:/etc/glance# export | grep OS declare -x LESSCLOSE="/usr/bin/lesspipe %s %s" declare -x OS_AUTH_KEY="openstack" declare -x OS_AUTH_TENANT="adminTenant" declare -x OS_AUTH_URL="http://172.16.70.129:5000/v2.0" declare -x OS_AUTH_USER="admin" declare -x OS_REGION_NAME="RegionOne"

keystone log: /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req /usr/lib/python2.7/dist-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated req.response.request = req 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] ***** REQUEST ENVIRON ***** 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] SCRIPT_NAME = /v2.0 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] webob.adhoc_attrs = {'response': <response at="" 0x3272610="" 200="" ok="">} 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] REQUEST_METHOD = POST 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] PATH_INFO = /tokens 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] SERVER_PROTOCOL = HTTP/1.0 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] CONTENT_LENGTH = 110 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] HTTP_USER_AGENT = glance-client 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] eventlet.posthooks = [] 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] SERVER_NAME = 172.16.70.129 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] REMOTE_ADDR = 172.16.70.236 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] eventlet.input = <eventlet.wsgi.input object="" at="" 0x370ce10=""> 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] wsgi.url_scheme = http 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] webob._body_file = (<limitedlengthfile(<eventlet.wsgi.input object="" at="" 0x370ce10="">, maxlen=110)>, <eventlet.wsgi.input object="" at="" 0x370ce10="">) 2012-04-12 16:27:15 DEBUG [keystone.common.wsgi] SERVER_PORT = 5000 2012-04-12 16:27:15 ... (more)

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2012-04-18 02:40:41 -0500

s-rain gravatar image

Thanks :)

edit flag offensive delete link more
0

answered 2012-04-12 14:06:11 -0500

jaypipes gravatar image

Anything in the glance-api log, Rain?

Best, -jay

edit flag offensive delete link more
0

answered 2012-04-13 01:26:57 -0500

s-rain gravatar image

Jay Thanks,

I fixed it after add glance endpoint in keystone.

There is a error as below when I install keyston in glance node.

Unpacking python-glance (from python-glance_2012.1~rc3-0ubuntu1_all.deb) ... dpkg: error processing python-glance_2012.1~rc3-0ubuntu1_all.deb (--install): trying to overwrite '/usr/share/pyshared/glance-2012.1.egg-info/dependency_links.txt', which is also in package glance 2012.1.4 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

After using "dpkg --force-overwrite -i python-glance_2012.1~rc3-0ubuntu1_all.deb" to install, keystone installed success. Is there any solution to avoid this error occurred?

Thanks,

Rain.

edit flag offensive delete link more
0

answered 2012-04-13 18:29:10 -0500

jaypipes gravatar image

Turning this into a packaging bug, Rain..

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-11 09:48:57 -0500

Seen: 39 times

Last updated: Apr 18 '12