Ask Your Question
0

floating IP - creating an IP pool on devstack

asked 2012-08-08 18:01:27 -0500

dubi-il gravatar image

devstack (Essex) comes with an existing pool of floating IPs (nova,test) which are not relevant to my local network. my devstack was installed on one host ( all components there) . I have created instances and run them.

I want to add a new IP range from my local network so that I can access an instance from outside the cloud .

I am using: nova-manage floating create --ip_range=<ip range=""> . The commad finishes with no comment But I cannot see the IP on the output of : nova-manage floating list . That output remains with the original list of IPs. Even if I erase them one by one and add mine last it is not added or at least no shown and not offered when I try to allocate Ip to a project from the dashboard or from nova command line

Any idea what is causing the problem or I have to use a different command syntax than explained in :http://docs.openstack.org/essex/openstack-compute/admin/content/associating-public-ip.html

my nova.conf has : my_ip=9.148.4.71 public_interface=br100 vlan_interface=eth0 flat_network_bridge=br100 flat_interface=eth0

and my host interface looks like :

br100 Link encap:Ethernet HWaddr 00:01:c9:00:00:18 inet addr:10.0.0.1 Bcast:10.0.0.255 Mask:255.255.255.0 inet6 addr: 2001:bf8:2000:2004:201:c9ff:fe00:18/64 Scope:Global inet6 addr: fe80::b84b:16ff:fe86:2727/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1705710 errors:0 dropped:913 overruns:0 frame:0 TX packets:432444 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:455514661 (455.5 MB) TX bytes:209287142 (209.2 MB)

eth0 Link encap:Ethernet HWaddr 00:01:c9:00:00:18 inet6 addr: 2001:bf8:2000:2004:201:c9ff:fe00:18/64 Scope:Global inet6 addr: fe80::201:c9ff:fe00:18/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:2337140 errors:0 dropped:0 overruns:0 frame:0 TX packets:716028 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:908411286 (908.4 MB) TX bytes:135346694 (135.3 MB) Interrupt:17 Memory:d8000000-d8012800

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:670528 errors:0 dropped:0 overruns:0 frame:0 TX packets:670528 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:7513813131 (7.5 GB) TX bytes:7513813131 (7.5 GB)

virbr0 Link encap:Ethernet HWaddr 6a:d2:5d:16:55:65 inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-08-14 12:19:20 -0500

johngarbutt gravatar image

Not sure why that command is failing, but you can take a look at adding a setting in your localrc file to adjust the range created by DevStack: FLOATING_RANGE=${FLOATING_RANGE:-172.24.4.224/28}

See: https://github.com/openstack-dev/devstack/blob/master/stack.sh#L285 (https://github.com/openstack-dev/devs...)

Looking at the docs, try without the --ip_range flag: http://docs.openstack.org/developer/nova/runnova/nova.manage.html#nova-floating-ips (http://docs.openstack.org/developer/n...)

The example commands in devstack are:

Create some floating ips

$NOVA_DIR/bin/nova-manage floating create $FLOATING_RANGE

Create a second pool

$NOVA_DIR/bin/nova-manage floating create --ip_range=$TEST_FLOATING_RANGE --pool=$TEST_FLOATING_POOL

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-08-08 18:01:27 -0500

Seen: 658 times

Last updated: Aug 14 '12