Ask Your Question
0

BadStatusLine: '' between Swift-proxy and Keystone (Ubuntu 12.04 - Havana)

asked 2013-10-24 08:21:13 -0500

thorfinn gravatar image

Hi all.

I installed Swift nodes on Ubuntu 12.04 and ubuntu-cloud-archives repo (Havana version) using these guides http://docs.openstack.org/havana/install-guide/install/apt/content/ch_swift.html (http://docs.openstack.org/havana/inst...) http://docs.openstack.org/developer/swift/howto_installmultinode.html (http://docs.openstack.org/developer/s...)

Here's our software configuration : * HAproxy : 192.168.3.251 # Swift Proxy listen dev-swiftproxy 0.0.0.0:8080 mode tcp balance source option tcplog option tcpka source 0.0.0.0 usesrc clientip server controller-1 192.168.3.111:8080 check inter 2000 rise 2 fall 5 server controller-2 192.168.3.211:8080 check inter 2000 rise 2 fall 5

        # Keystone
        listen dev-auth-public 0.0.0.0:5000
          mode http
          balance source
          option  httplog
          option  httpclose
          option  forwardfor
          server controller1 192.168.3.141:5000 check inter 2000 rise 2 fall 5
          server controller2 192.168.3.241:5000 check inter 2000 rise 2 fall 5
        listen dev-auth-admin 0.0.0.0:35357
          mode http
          balance source
          option  httplog
          option  httpclose
          option  forwardfor
          server controller1 192.168.3.141:35357 check inter 2000 rise 2 fall 5
          server controller2 192.168.3.241:35357 check inter 2000 rise 2 fall 5

    * Keystone 1 : 192.168.3.141
    * Keystone 2 : 192.168.3.241

    * Swift proxy 1 : 192.168.3.111
    * Swift proxy 2 : 192.168.3.211

My proxy-server.conf is: [DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

    [pipeline:main]
    pipeline = healthcheck cache authtoken keystoneauth proxy-server

    [app:proxy-server]
    use = egg:swift#proxy
    allow_account_management = true
    account_autocreate = true

    [filter:keystoneauth]
    use = egg:swift#keystoneauth
    operator_roles = admin

    [filter:authtoken]
    paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

    # Delaying the auth decision is required to support token-less
    # usage for anonymous referrers ('.r:*').
    delay_auth_decision = true

    # cache directory for signing certificate
    signing_dir = /home/swift/keystone-signing

    # auth_* settings refer to the Keystone server
    auth_protocol = http
    auth_host = 192.168.3.251
    auth_port = 35357

    # the same admin_token as provided in keystone.conf
    admin_token = pass

    # the service tenant and swift userid and password created in Keystone
    admin_tenant_name = service
    admin_user = swift
    admin_password = swift

    [filter:cache]
    use = egg:swift#memcache
    memcache_servers = 192.168.1.111:11211

    [filter:catch_errors]
    use = egg:swift#catch_errors

    [filter:healthcheck]
    use = egg:swift#healthcheck

In the "Verify the installation" part when I execute (through HAProxy) : # swift --debug -V 2.0 -A http://192.168.3.251:5000/v2.0 -U service:swift -K swift stat

I have this error : # swift --debug -V 2.0 -A http://192.168.3.251:5000/v2.0 -U service:swift -K swift stat REQ: curl -i -X POST http://192.168.3.251:5000/v2.0/tokens -H "Content-Type: application/json" -H "User-Agent: python-keystoneclient" DEBUG:keystoneclient.httpclient:REQ: curl -i -X POST http://192.168.3.251:5000/v2.0/tokens -H "Content-Type: application/json" -H "User-Agent: python-keystoneclient" REQ BODY: {"auth": {"tenantName": "service", "passwordCredentials": {"username": "swift", "password": "swift"}}}

    DEBUG:keystoneclient.httpclient:REQ BODY: {"auth": {"tenantName": "service", "passwordCredentials": {"username": "swift", "password": "swift"}}}

    INFO:urllib3 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-10-25 07:49:30 -0500

thorfinn gravatar image

I have remove the ssl certificate. Thank you for the information My problem is solved. It's a problem with my haproxy conf.

edit flag offensive delete link more
0

answered 2013-10-25 06:32:25 -0500

esedmehmet gravatar image

Why you use ssl cretificate in proxy-server.conf? Keystone is ensured ssl security for swift. you have to remove cert_file and key file in proxy_server.conf. And you will restart the proxy service. [DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-10-24 08:21:13 -0500

Seen: 312 times

Last updated: Oct 25 '13