Ask Your Question
0

nova doesn't work unless using -no-cache option

asked 2013-02-23 02:33:24 -0600

Hi All,

I have a question that i know someone can answer because it's a straightforward one.

Symptom: When running Nova commands, it is trying to reach an incorrect management server and therefore fails everytime. (I verify this by doing the --debug command). However, when I use the --no-cache option, which means it won't use the authentication cache, everything works normal.

Actions Taken with no success: -Removed all openstack related packages by doing --purge remove and then re-installed everything -deleted the entire sql database

Despite all of this, it is still trying to reach a server I had set up previously which is incorrect. Where is it getting this "cached" information from and how do I remove it? Thank you!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-02-23 12:58:29 -0600

I found out that my keyring was being cached in my ~/.local folder and I had to delete python_keyring.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-02-23 02:33:24 -0600

Seen: 4 times

Last updated: Feb 23 '13