Ask Your Question
0

Image operations result in MultipleChoice exceptions

asked 2013-02-15 17:05:06 -0600

Im trying to setup glance and add a new image. db_sync ran cleanly and the database appears to be OK. However any attempt to add a new image or view images results in the following errors:

glance add name="Ubuntu 12.04 LTS" is_public=true container_format=ovf disk_format=qcow2 location=file://pwd/images/ubuntu-12.04-server-cloudimg-amd64-disk1.img

Failed to add image. Got error: The request returned a 302 Multiple Choices. This generally means that you have not included a version indicator in a request URI.

The body of response returned: {"versions": [{"status": "CURRENT", "id": "v1.1", "links": [{"href": "http://127.0.0.1:9292/v1/", "rel": "self"}]}, {"status": "SUPPORTED", "id": "v1.0", "links": [{"href": "http://127.0.0.1:9292/v1/", "rel": "self"}]}]} Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'.

Any clues as to what might be misconfigured to cause this?

thanks...

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2013-02-15 22:44:27 -0600

which version of glance are you using?

edit flag offensive delete link more
0

answered 2013-02-20 00:09:03 -0600

Apparently, Im using 2012.1.3-dev on Ubuntu 12.04

glance --version

glance 2012.1.3-dev

edit flag offensive delete link more
0

answered 2013-02-20 00:11:28 -0600

Also, any glance comment seems to cause the problem. Im sure it's probably a configuration problem but I cant figure out what it would be.

glance index

Failed to show index. Got error: The request returned a 302 Multiple Choices. This generally means that you have not included a version indicator in a request URI.

The body of response returned: {"versions": [{"status": "CURRENT", "id": "v1.1", "links": [{"href": "http://127.0.0.1:9292/v1/", "rel": "self"}]}, {"status": "SUPPORTED", "id": "v1.0", "links": [{"href": "http://127.0.0.1:9292/v1/", "rel": "self"}]}]}

edit flag offensive delete link more
0

answered 2013-02-20 22:46:53 -0600

zzs gravatar image

This problem happened before and already solved, please check here: https://answers.launchpad.net/glance/+question/179616 (https://answers.launchpad.net/glance/...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-02-15 17:05:06 -0600

Seen: 22 times

Last updated: Feb 20 '13