Ask Your Question
0

QueuePool limit of size 5 overflow 10 reached, connection timed out, timeout 30

asked 2014-02-24 13:56:47 -0500

sasikanth gravatar image

Hi,

I am facing an issue while creating concurrent volumes, this is what I am able to obtain from api.log,

2014-02-24 19:10:43.939 3986 TRACE cinder.api.middleware.fault rec = self._connection_record = pool._do_get() 2014-02-24 19:10:43.939 3986 TRACE cinder.api.middleware.fault File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/pool.py", line 729, in _do_get 2014-02-24 19:10:43.939 3986 TRACE cinder.api.middleware.fault (self.size(), self.overflow(), self._timeout)) 2014-02-24 19:10:43.939 3986 TRACE cinder.api.middleware.fault TimeoutError: QueuePool limit of size 5 overflow 10 reached, connection timed out, timeout 30 2014-02-24 19:10:43.939 3986 TRACE cinder.api.middleware.fault 2014-02-24 19:10:51.665 3986 ERROR cinder.api.middleware.fault [req-735a0686-11cf-425a-af07-eace696c969b f0f3b3a3ad58426da172e3f7faec3778 f29896eef5bb40298744487dd946d332] Caught error: QueuePool limit of size 5 overflow 10 reached, connection timed out, timeout 30

In order to solve this, I searched over the documentation available and modified the following values in cinder.conf;

connection=sqlite:////cinder/openstack/common/db/$sqlite_db idle_timeout=3600 min_pool_size=1 max_pool_size=5000 max_overflow=-1

and restarted api, scheduler, volume. services, but still facing the same issue. let me know if i need to update any entires in cinder.conf

Regards, Sasi

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-02-25 05:40:54 -0500

lvhancy gravatar image

If the log shows same error that "Caught error: QueuePool limit of size 5 overflow 10 reached, connection timed out, timeout 30", may be your items still don't work. Make sure these related items in the "database" section in cinder.conf. Like:

""" [database] connection=sqlite:////cinder/openstack/common/db/$sqlite_db max_overflow=-1 max_pool_size=5000 """

Or, you can also modefy these value directly in cinder.openstack.common.db.sqlalchemy.session.py: database_opts. Then restart the cinder-api, have a try again.

Otherwise, these bugs may help you: https://bugs.launchpad.net/nova/+bug/1181372 (https://bugs.launchpad.net/nova/+bug/...) https://bugs.launchpad.net/ceilometer/+bug/1243251 (https://bugs.launchpad.net/ceilometer...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-02-24 13:56:47 -0500

Seen: 5,201 times

Last updated: Feb 25 '14