Ask Your Question
0

instance nonet interface

asked 2012-06-12 14:05:12 -0500

ronan-lanore gravatar image

I don't understand why my instance wait for network device

In consle log for my test instance: .... .... cloud-init start-local running: Tue, 12 Jun 2012 13:20:30 +0000. up 19.38 seconds no instance data found in start-local cloud-init-nonet waiting 120 seconds for a network device. cloud-init-nonet gave up waiting for a network device. ci-info: lo : 1 127.0.0.1 255.0.0.0 . ci-info: eth0 : 1 . . fa:16:3e:37:4a:f3 route_info failed * Stopping Handle applying cloud-config[74G[ OK ] ... ... The openstack installation is all-in-one

The instance image come from : http://uec-images.ubuntu.com/releases/precise/release/ubuntu-12.04-server-cloudimg-amd64-disk1.img (http://uec-images.ubuntu.com/releases...)

My Network configuration is as follow: auto tap0 iface tap0 inet manual up ifconfig $IFACE up down ifconfig $IFACE down tunctl_user hebus

Public network

auto br0 iface br0 inet static bridge_ports tap0 address 192.168.0.100 netmask 255.255.255.0 gateway 192.168.0.254 broadcast 192.168.0.255

auto tap2 iface tap2 inet manual up ifconfig $IFACE up down ifconfig $IFACE down tunctl_user hebus

Private Network

auto br2 iface br2 inet static bridge_ports tap2 address 172.16.100.1 netmask 255.255.255.0 broadcast 172.16.100.255

the nova.conf for network :

network specific settings

network_manager=nova.network.manager.FlatDHCPManager public_interface=br0 flat_interface=tap2 flat_network_bridge=br2 fixed_range=172.16.100.0/24 flat_network_dhcp_start=172.16.100.2 floating_range=192.168.0.0/24 flat_injected=False

I have create a private network as: nova-manage network create private --fixed_range_v4=172.16.100.0/24 --bridge_interface=br100 --num_networks=1 --network_size=256

The nova-network is runing : troy:~# ps -edf| grep nova-network nova 7473 1 0 15:14 ? 00:00:12 /usr/bin/python /usr/bin/nova-network --flagfile=/etc/nova/nova.conf

The dnsmasq is runing too: troy:~# ps -edf| grep dnsmasq nobody 6748 1 0 15:13 ? 00:00:00 /usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/bridge_172.16.0.1.pid --conf-file= --except-interface lo --listen-address 172.16.0.1 --dhcp-range 172.16.0.128,172.16.0.254 --dhcp-leasefile=/var/lib/libvirt/dnsmasq/bridge_172.16.0.1.leases --dhcp-lease-max=127 --dhcp-no-override --dhcp-hostsfile=/var/lib/libvirt/dnsmasq/bridge_172.16.0.1.hostsfile nobody 8486 1 0 15:14 ? 00:00:00 /usr/sbin/dnsmasq --strict-order --bind-interfaces --conf-file= --domain=novalocal --pid-file=/home/hebus/Documents/kvm/nova/networks/nova-br2.pid --listen-address=172.16.100.1 --except-interface=lo --dhcp-range=172.16.100.2,static,120s --dhcp-lease-max=256 --dhcp-hostsfile=/home/hebus/Documents/kvm/nova/networks/nova-br2.conf --dhcp-script=/usr/bin/nova-dhcpbridge --leasefile-ro root 8489 8486 0 15:14 ? 00:00:00 /usr/sbin/dnsmasq --strict-order --bind-interfaces --conf-file= --domain=novalocal --pid-file=/home/hebus/Documents/kvm/nova/networks/nova-br2.pid --listen-address=172.16.100.1 --except-interface=lo --dhcp-range=172.16.100.2,static,120s --dhcp-lease-max=256 --dhcp-hostsfile=/home/hebus/Documents/kvm/nova/networks/nova-br2.conf --dhcp-script=/usr/bin/nova-dhcpbridge --leasefile-ro

I have no error at instance boot time into nova-network.log

So what is wrong with this config ?

thanks

edit retag flag offensive close merge delete

5 answers

Sort by » oldest newest most voted
0

answered 2012-06-13 08:44:41 -0500

ronan-lanore gravatar image

into /var/log/syslog i have this message:

dnsmasq-dhcp[12448]: DHCPDISCOVER(br2) fa:16:3e:59:90:fd no address available

I don't understand why dnsmasq refuse to assign an adress

edit flag offensive delete link more
0

answered 2012-06-19 10:06:49 -0500

ronan-lanore gravatar image

I have used Debian sid and his package for test openstack. I think the package aren't on essex last commit/version.

Problem solved by start openstack from git checkout

edit flag offensive delete link more
0

answered 2012-06-13 09:59:50 -0500

ronan-lanore gravatar image

so that my instance get an ip i have to edit

/home/hebus/Documents/kvm/nova/networks/nova-br2.conf

and add

fa:16:3e:59:90:fd,hebus,172.16.100.2

Is that what is normal?

edit flag offensive delete link more
0

answered 2012-06-12 14:17:12 -0500

ronan-lanore gravatar image

Here the ifconfig output on host and brctl show

ifconfig br0 Link encap:Ethernet HWaddr ae:44:8d:dd:96:63
inet adr:192.168.0.100 Bcast:192.168.0.255 Masque:255.255.255.0 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 lg file transmission:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

br2 Link encap:Ethernet HWaddr 26:ed:7b:38:d9:b9
inet adr:172.16.100.1 Bcast:172.16.100.255 Masque:255.255.255.0 adr inet6: fe80::24ed:7bff:fe38:d9b9/64 Scope:Lien UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:26 errors:0 dropped:0 overruns:0 frame:0 TX packets:95 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 lg file transmission:0 RX bytes:7760 (7.5 KiB) TX bytes:10818 (10.5 KiB)

eth0 Link encap:Ethernet HWaddr 00:1b:38:4f:4a:cb
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 lg file transmission:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) Interruption:18

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0 adr inet6: ::1/128 Scope:Hôte UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:57233 errors:0 dropped:0 overruns:0 frame:0 TX packets:57233 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 lg file transmission:0 RX bytes:34505200 (32.9 MiB) TX bytes:34505200 (32.9 MiB)

tap0 Link encap:Ethernet HWaddr ae:44:8d:dd:96:63
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 lg file transmission:500 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

tap2 Link encap:Ethernet HWaddr 26:ed:7b:38:d9:b9
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 lg file transmission:500 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

virbr1 Link encap:Ethernet HWaddr c2:de:56:67:98:63
inet adr:172.16.0.1 Bcast:172.16.0.255 Masque:255.255.255.0 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 lg file transmission:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

vnet0 Link encap:Ethernet HWaddr fe:16:3e:2f:3f:1b
adr ...
(more)

edit flag offensive delete link more
0

answered 2012-06-13 08:34:41 -0500

ronan-lanore gravatar image

I made a mistake on create network with nova-manage

I have create a private network as: nova-manage network create private --fixed_range_v4=172.16.100.0/24 --bridge_interface=br100 --num_networks=1 --network_size=256

I destroyed this network to create another with this command line

nova-manage network create private --fixed_range_v4=172.16.100.0/24 --num_networks=1 --bridge=br2 --bridge_interface=tap2 --network_size=256

After a reboot the problem is still here

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-06-12 14:05:12 -0500

Seen: 110 times

Last updated: Jun 19 '12