Ask Your Question
0

trying Qpid on Ubuntu 12.04 -- ClassNotFound exception

asked 2012-05-21 13:36:07 -0500

Hi,

I have nova Essex over Ubuntu-12.04 installed on my cluster. I am trying to experiment with the Qpid instead of RabbitMQ. I have installed Qpid and its other utilities using the following command: apt-get install qpidd qpid-tools qpid-doc qpid-client python-qpid-extras-qmf python-qpid python-cqpid

and have enabled the quid backend using the following flags in nova.conf --rpc_backend=nova.rpc.impl_qpid --qpid_hostname=192.168.1.7

But when I start nova-compute and other nova services, they are unable to find impl_qpid; the exact error from nova-compute.log is: 2012-05-21 08:58:13 TRACE nova ClassNotFound: Class impl_qpid could not be found: 'module' object has no attribute 'impl_qpid'

However, I can see impl_qpid.py and impl_qpid.pyc in /usr/lib/python2.7/dist-packages/nova/rpc. Please let me know where am I going wrong.

I have am pasting the relevant portions of nova-compute.log and nova.conf below

thanks in advance -upendra

===== nova.conf ==== --dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --force_dhcp_release --iscsi_helper=tgtadm --libvirt_use_virtio_for_bridges --connection_type=libvirt --root_helper=sudo nova-rootwrap --verbose --debug --ec2_private_dns_show_ip --auth_strategy=keystone

GLANCE

--image_service=nova.image.glance.GlanceImageService --glance_api_servers=192.168.1.4:9292

RPC backend

rabbit

#--rabbit_host=192.168.1.4 --rabbit_host=192.168.1.6

Qpid

--rpc_backend=nova.rpc.impl_qpid --qpid_hostname=192.168.1.7

NETWORK

--network_manager=nova.network.manager.FlatDHCPManager --flat_injected=False --fixed_range=192.168.100.0/24 --public_interface=eth0 --flat_interface=eth2 --flat_network_bridge=br100 --multi_host=True

DATABASE

--sql_connection=mysql://nova:nova@192.168.1.4/nova

========== nova-compute.log ============== 2012-05-21 08:58:09 DEBUG nova.service [-] network_driver : nova.network.linux_net from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] quota_instances : 10 from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] vnc_keymap : FLAG SET from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:409 2012-05-21 08:58:09 DEBUG nova.service [-] image_service : nova.image.glance.GlanceImageService from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] libvirt_inject_password : FLAG SET from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:409 2012-05-21 08:58:09 DEBUG nova.service [-] control_exchange : nova from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] volume_group : nova-volumes from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] log_file : None from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] compute_manager : nova.compute.manager.ComputeManager from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] compute_driver : nova.virt.connection.get_connection from (pid=5173) wait /usr/lib/python2.7/dist-packages/nova/service.py:411 2012-05-21 08:58:09 DEBUG nova.service [-] network_topic : network from ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-05-22 00:58:42 -0500

Managed to find the solution.

I had not installed the necessary libraries for Qpid on 192.168.1.4 and thus that error. The error message was misleading but did give a hint of the main problem.

so just ran the following on 192.168.1.4 also apt-get install qpidd qpid-tools qpid-doc qpid-client python-qpid-extras-qmf python-qpid python-cqpid

-u

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-05-21 13:36:07 -0500

Seen: 32 times

Last updated: May 22 '12