Ask Your Question
0

Unable to create a VM

asked 2013-04-09 11:48:40 -0500

davija gravatar image

updated 2013-04-09 11:49:27 -0500

I am new to openstack and have been having some trouble getting things configured correctly and launch a VM successfully.

I am using ubuntu 12.04 LTS, Openstack Folsom and using the puppetopenstack based installation.

Currently I am unable to create a VM (Goes into an error state when I try to launch it). Looking through the logs, I am not able to see anything offhand that is causing it. Due to the large number of pieces involved with openstack, I am unsure where to start looking on this, any help would be appreciated.

Current configuration uses two NICs, and an all-in-one controller/network/compute node with nova for networking.

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
1

answered 2013-04-09 12:45:57 -0500

Start with nova-api.log on controller node and nova-compute.log on compute node. Make sure that log level is set to debug in nova.conf.

edit flag offensive delete link more
0

answered 2013-10-03 06:09:19 -0500

sngirame gravatar image

I had encountered similar error when hardware virtualization was not enabled on compute node.

edit flag offensive delete link more

Comments

i am facing similiar issue, all service are up and running, my env is that compute node is actually a VM i.e KV guest its centos 7, how can i make my vm to spawn...

Mohd Ali gravatar imageMohd Ali ( 2017-08-20 06:40:34 -0500 )edit
0

answered 2013-04-26 08:24:56 -0500

vedanu gravatar image

Hi,

Even I have create the setup using the open stack folsom version and OS Ubuntu 12.04 version.

below is the link that I used to setup my nodes. https://github.com/mseknibilel/OpenStack-Folsom-Install-guide/blob/master/OpenStack_Folsom_Install_Guide_WebVersion.rst (https://github.com/mseknibilel/OpenStack-Folsom-Install-guide/blob/master/OpenStackFolsomInstallGuideWebVersion.rst)

In my controller node :


root@ControllerOS:/var/log/nova# nova-manage service list
2007-10-29 10:40:46 DEBUG nova.utils [req-150b5ede-0ec0-4388-822c-fe6cd56cfc4a None None] backend <module 'nova.db.sqlalchemy.api' from '/usr/lib/python2.7/dist-packages/nova/db/sqlalchemy/api.pyc'> __get_backend /usr/lib/python2.7/dist-packages/nova/utils.py:506
Binary           Host                                 Zone             Status     State Updated_At
nova-consoleauth ControllerOS                         nova             enabled    :-)   2007-10-29 05:10:48
nova-scheduler   ControllerOS                         nova             enabled    :-)   2007-10-29 05:10:46
nova-compute     ComputeOS                            nova             enabled    XXX   2013-04-26 18:29:27

In my compute node:



2013-04-27 00:00:30 DEBUG nova.utils [req-4448a4ca-1ff6-4e5f-bf04-558117be84f8 None None] backend <module 'nova.db.sqlalchemy.api'="" from="" '="" usr="" lib="" python2.7="" dist-packages="" nova="" db="" sqlalchemy="" api.pyc'=""> _getbackend /usr/lib/python2.7/dist-packages/nova/utils.py:506

Binary           Host                                 Zone             Status     State Updated_At
nova-consoleauth ControllerOS                         nova             enabled    XXX   2007-10-29 05:11:49
nova-scheduler   ControllerOS                         nova             enabled    XXX   2007-10-29 05:11:56
nova-compute     ComputeOS                            nova             enabled    :-)   2013-04-26 18:30:38

root@ComputeOS:/var/log/nova#


All other process like quantum agent, dhcp, l3 agent, libvirt on the nodes are up and running with out error.

When I launch VM, I get status error.

Log Info :

Compute Node:

Nova Manage:

2013-04-27 00:00:30 DEBUG nova.utils [req-4448a4ca-1ff6-4e5f-bf04-558117be84f8 None None] backend <module 'nova.db.sqlalchemy.api' from '/usr/lib/python2.7/dist-packages/nova/db/sqlalchemy/api.pyc'> __get_backend /usr/lib/python2.7/dist-packages/nova/utils.py:506

Nova Compute:

2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Running periodic task ComputeManager._poll_bandwidth_usage periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:172
2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Running periodic task ComputeManager._poll_rebooting_instances periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:172
2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Skipping ComputeManager._cleanup_running_deleted_instances, 22 ticks left until next run periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:167
2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Running periodic task ComputeManager._check_instance_build_time periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:172
2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Running periodic task ComputeManager._heal_instance_info_cache periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:172
2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Running periodic task ComputeManager._run_image_cache_manager_pass periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:172
2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Running periodic task ComputeManager._reclaim_queued_deletes periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:172
2013-04-27 00:09:06 15633 DEBUG nova.compute.manager [-] FLAGS.reclaim_instance_interval <= 0, skipping... _reclaim_queued_deletes /usr/lib/python2.7/dist-packages/nova/compute/manager.py:2802
2013-04-27 00:09:06 15633 DEBUG nova.manager [-] Running periodic task ComputeManager._report_driver_status periodic_tasks /usr/lib/python2.7/dist-packages/nova/manager.py:172
2013-04-27 00:09:06 15633 INFO nova.compute ...
(more)
edit flag offensive delete link more
0

answered 2013-04-17 04:15:00 -0500

RomilGupta gravatar image

Hi ,

Firstly , put a debug flag in nova.conf i.e debug = true for grizzly or verbose=true

then , check whether all your services are running or not ? Command : nova-manage service list

if any of the service is not working , check the log file available in /var/log/<component-name>/<service-name> directory and then post the error stack.

To debug the nova-boot issue check the compute and scheduler logs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-09 11:48:40 -0500

Seen: 673 times

Last updated: Oct 03 '13