Ask Your Question
0

swift works with OS_AUTH_URL but not '-A'

asked 2013-02-19 15:47:15 -0600

jas-z gravatar image

I am trying to set up a simple openstack swift + keystone environment. I can get it to work if I define OS_AUTH_URL, but when I instead specify -A and the same url I used in the environment variable I get "

Auth GET failed: http://localhost:5000/v2.0/ 200 OK

for example:

[jas@psfcstor1 swift]$ echo $OS_AUTH_URL http://psfcstor1:5000/v2.0 [jas@psfcstor1 swift]$ swift -U demo:admin -K xxxx list josh nthoward unique

the same thing -A [jas@psfcstor1 swift]$ unset OS_AUTH_URL [jas@psfcstor1 swift]$ swift -A http://psfcstor1:5000/v2.0 -U demo:admin -K xxxx list
Auth GET failed: http://psfcstor1:5000/v2.0/ 200 OK

I thought these should be equivalent ....

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-02-19 18:41:49 -0600

cthier gravatar image

hehe... well -A isn't deprecated, but part of the legacy auth arguments.


Chuck

On Tue, Feb 19, 2013 at 12:36 PM, Josh Stillerman question222292@answers.launchpad.net wrote:

Question #222292 on OpenStack Object Storage (swift) changed: https://answers.launchpad.net/swift/+question/222292 (https://answers.launchpad.net/swift/+...)

Status: Open => Solved

Josh Stillerman confirmed that the question is solved: I nice person on the openstack IRC solved this for me.

+creiht

suggested I use os_auth_url instead of -A, which worked. He explained that -A was deprecated.


You received this question notification because you are an answer contact for OpenStack Object Storage (swift).

edit flag offensive delete link more
0

answered 2013-02-19 17:54:58 -0600

jas-z gravatar image

A bit more information.... If I ask keystone about the endpoints and grep it for the identity service I get:

[root@psfcstor1 ~]# keystone endpoint-list | grep 361e565ef6cc44cc8f93dc1c092dd8c0 | c42e3c8705684113aee96caf33ddd07b | RegionOne | http://localhost:$(public_port)s/v2.0 | http://localhost:$(public_port)s/v2.0 | http://localhost:$(admin_port)s/v2.0 | 361e565ef6cc44cc8f93dc1c092dd8c0 |

now localhost should work (I am logged on to the same computer) but I am guessing that some of these should be the external IP of the computer ?

edit flag offensive delete link more
0

answered 2013-02-19 18:32:12 -0600

jas-z gravatar image

I nice person on the openstack IRC solved this for me.

+creiht

suggested I use os_auth_url instead of -A, which worked. He explained that -A was deprecated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-02-19 15:47:15 -0600

Seen: 36 times

Last updated: Feb 19 '13