Ask Your Question
3

How to get DevStack VMs to access the internet

asked 2013-06-05 00:35:27 -0500

Sovietaced gravatar image

updated 2013-08-09 03:45:18 -0500

rahmu gravatar image

Right now when I launch devstack VMs with folsom + floodlight quantum plugin I can launch VMs no problem and ssh into them. Everything is great until I get into the VM launched and try to do anything that uses the internet.

One immediate problem that I found is that for some reason the default gateway is always incorrect. In a 10.0.0.0/24 network the default gateway is 10.0.0.1 when in it always seems to really be 10.0.0.2. This dumps all external pointing traffic down a black hole.

In addition to this whenever I add another default gateway and remove the original it seems that every minute or so the default routes are restored, ie 10.0.0.1. No matter what I do my changes will be reset every minute. What's going on here?

edit retag flag offensive close merge delete

Comments

1

Could you please share your neutron config?

rms_13 gravatar imagerms_13 ( 2013-09-13 00:14:32 -0500 )edit

Are you sure your DNS-Server IP is correct?

muehsi gravatar imagemuehsi ( 2013-10-23 05:11:09 -0500 )edit
2

You asked this question >4mo ago, so almost certainly you've resolved the matter by now... would you mind sharing how you fixed the problem, and what you learned in the process?

PaulReiber gravatar imagePaulReiber ( 2013-11-14 16:09:16 -0500 )edit

Did anyone find resolution to this problem please ??? Thanks.

bubuli gravatar imagebubuli ( 2013-12-18 10:26:28 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-02-24 00:36:17 -0500

MoizArif gravatar image

There are a couple of things you need to do in order to get internet access on the instances.

Firstly, starting from the basics, your br-ex should include the physical ethernet port used for connecting to the ethernet. Use the br-ex to get IP from the local lan (assuming 192.168.1.x) network. Your br-int should be responsible for handing out IPs to the virtual machines 10.x.x.x network.

Secondly, create a router in neutron with one port with IP 10.0.0.1 connected to the 10.x.x.x network and other port connected to the local lan side with gateway ip set to the actual ip of the lan network gateway (192.168.1.1).

Thirdly, configure your floating ip pool to assign IP addresses from the local lan IP Range (192.168.1.x in this example). Associate the floating IP to the instance and you should get the internet connectivity.

Hope this helps for all of you. If you still get stuck than provide more details from your setup for debugging and troubleshooting.

edit flag offensive delete link more

Comments

What do you mean "local lan"? Is it external network?

Allen Liu gravatar imageAllen Liu ( 2015-10-22 15:48:19 -0500 )edit
1

answered 2014-05-13 04:47:06 -0500

SGPJ gravatar image

Also you need to have proper rules in security group.

edit flag offensive delete link more
0

answered 2014-04-21 10:03:09 -0500

mani619cash gravatar image

I solved the problem by executing this command on my Devstack machine:

sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

This way you SNAT your "public" network and the VMs can receive the Internet traffic.

Don't forget to give floating IPs to yout VMs!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

5 followers

Stats

Asked: 2013-06-05 00:35:27 -0500

Seen: 2,506 times

Last updated: May 13 '14