Ask Your Question
0

quantum net-list Connection refused

asked 2013-05-17 10:08:18 -0500

graklaudia gravatar image

hi, it becomes puzzling: instaulując werję grizzly step by step, I can not do with network options noda quantum net-list or anything else but associated with Quantum, is the answer

"[Errno 111] Connection refused".

also trying to do this query on the controller node connection is refused.

Is anyone able to identify it?

edit retag flag offensive close merge delete

13 answers

Sort by » oldest newest most voted
0

answered 2013-06-12 15:03:00 -0500

emagana gravatar image

Klaudia,

I think that the problem is because you have all your services running on: 127.0.0.1 When you run commands from controller, everything is working because all calls are local but when running from a different node is still trying to reach: REQ: curl -i http://127.0.0.1:9696/v2.0/networks.json -X GET

When you set up your controller, use the IP address that is reachable between your nodes.

edit flag offensive delete link more
0

answered 2013-06-13 10:17:32 -0500

graklaudia gravatar image

Edgar, Thank you for your reply. It can be this problem , as you noticed. I'm trying to find the files that contain the phrase '127 .0.0.1 ' , and can be conneted with quantum problems. well... there are many files containing 127.0.0.1 (grep 127.0.0.1 -r /) , but which one could be this, where I have to do exnage 127.0.0.1 on controller addres?

I tryided to find this in quantum catalog: grep 127.0.0.1 -r /etc/quantum/ , but there are not '127.0.0.1' phrase there.

I find for example that in patch: /usr/lib/python2.7/dist-packages/quantum/agent/l3_agent.py is 127.0.0.1 in function

def metadata_filter_rules(self): rules = [] rules.append(('INPUT', '-s 0.0.0.0/0 -d 127.0.0.1 ' '-p tcp -m tcp --dport %s ' '-j ACCEPT' % self.conf.metadata_port)) return rules

But I do not know if I change the code in this place or elsewhere, and how to restart it later. I could ask for help from a file where I find the files where you need to replace the phrase 127.0.0.1 to another address, the address of the Controller?

edit flag offensive delete link more
0

answered 2013-06-13 16:18:02 -0500

jamo gravatar image

Klaudia,

when you set up your controller with whatever method(s) you are using, you need to make sure the keystone endpoints are using the reachable ip address. If this was an automated setup, then search through the config files for that automation. If it was manual, then you probably actually typed 127.0.0.1 for the address to "keystone endpoint-create ..."

my first setup was manual according to this guide: https://github.com/mseknibilel/OpenStack-Folsom-Install-guide (https://github.com/mseknibilel/OpenSt...)

that guide provided me with a script that created the endpoints: https://github.com/mseknibilel/OpenStack-Folsom-Install-guide/tree/master/Keystone_Scripts (https://github.com/mseknibilel/OpenSt...)

you can manually delete and remake your endpoints "keystone endpoint-delete ..." then "keystone endpoint-create ..."

good luck. JamO

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-17 10:08:18 -0500

Seen: 319 times

Last updated: Aug 03 '13