swauth and token_life

asked 2013-08-20 21:10:06 -0600

simplidrive gravatar image

Hi,

I have set the token_life (under swauth in proxy-server.conf) to 4320000 (which is 50 days)

still when i get the token, the value of X-Auth-Token-Expires is 80179 (which is 24 hours)

how do I make a token life to 4320000 (which is 50 days)?

I also tried putting max_token_life to 4320000 (which is 50 days) along with it, but still the same result.

The version of swift is 1.9.0 and swauth version is 1.0.9

any suggestions ?

Regards,

Viral

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-08-21 04:37:33 -0600

simplidrive gravatar image

Thanks clayg, that solved my question.

edit flag offensive delete link more
0

answered 2013-08-20 22:01:42 -0600

clay-gerrard gravatar image

Setting token_life opiton in the config should do the trick for new tokens, dunno if you're getting a new token though. You could try to send "X-Auth-New-Token: true" along with your auth request, or delete all the tokens from the swauth containers and restart memcache to be sure. Also the client can apparently send over "X-Auth-Token-Lifetime" which can be any value up to max_token_life - so watch out not to do that, or do that and see if it makes a difference.

If you still can't find anything that works you can report the issue to swauth:

https://github.com/gholt/swauth/issues

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-20 21:10:06 -0600

Seen: 83 times

Last updated: Aug 21 '13