Ask Your Question
0

Use Linux bridge to assign networks, but not IPs

asked 2013-05-22 19:50:54 -0500

zestrada gravatar image

I have setup quantum with the linux bridge plugin. For now, I'm not looking to do IPAM in quantum, just to create networks. I want to assign VMs to networks without IP subnets, but if i do that then nova doesn't create network interfaces for those VMs (no errors in either compute.log or linuxbridge-agent.log).

Here's an example:

[root@cloud1 ~(keystone_admin)]# quantum net-create lab-test --tenant_id 60899984662e4f38b703f7126de48473 --provider:network_type flat --provider:physical_network testnet Created a new network: +---------------------------+--------------------------------------+ | Field | Value | +---------------------------+--------------------------------------+ | admin_state_up | True | | id | 29989e92-3210-4d7c-af1b-dba53165352b | | name | lab-test | | provider:network_type | flat | | provider:physical_network | testnet | | provider:segmentation_id | | | router:external | False | | shared | False | | status | ACTIVE | | subnets | | | tenant_id | 60899984662e4f38b703f7126de48473 |

+---------------------------+--------------------------------------+


[root@cloud1 ~(keystone_user)]$ nova boot --flavor m1.small --image rh6 --nic net-id=29989e92-3210-4d7c-af1b-dba53165352b test

testnet does exist in the plugin.ini:

network_vlan_ranges = testnet:100:200 ...

physical_interface_mappings = testnet:vbr-em1

Inside the vm, I only have the "lo" interface. If I create a subnet, then an eth0 device gets created. I've tried both "flat" and "vlan" for network_type.

What's the right way to do this?

Thanks!

edit retag flag offensive close merge delete

16 answers

Sort by ยป oldest newest most voted
0

answered 2013-07-14 09:25:40 -0500

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

edit flag offensive delete link more
0

answered 2013-07-14 21:22:45 -0500

zestrada gravatar image

Not sure how to get traction on this On Jul 14, 2013 4:26 AM, "Launchpad Janitor" < question229425@answers.launchpad.net > wrote:

Your question #229425 on neutron changed: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

Status: Open => Expired

Launchpad Janitor expired the question: This question was expired because it remained in the 'Open' state without activity for the last 15 days.


If you're still having this problem, you can reopen your question either by replying to this email or by going to the following page and entering more information about your problem: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

You received this question notification because you asked the question.

edit flag offensive delete link more
0

answered 2013-07-14 23:20:34 -0500

emagana gravatar image

Did you try creating network and subnet with NO DHCP? You can do the following: quantum subnet-create network-name 192.168.0.0/24 --enable_dhcp False

edit flag offensive delete link more
0

answered 2013-07-31 12:41:14 -0500

zestrada gravatar image

Reopening On Jul 31, 2013 4:31 AM, "Launchpad Janitor" < question229425@answers.launchpad.net > wrote:

Your question #229425 on neutron changed: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

Status: Open => Expired

Launchpad Janitor expired the question: This question was expired because it remained in the 'Open' state without activity for the last 15 days.


If you're still having this problem, you can reopen your question either by replying to this email or by going to the following page and entering more information about your problem: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

You received this question notification because you asked the question.

edit flag offensive delete link more
0

answered 2013-07-31 14:11:38 -0500

salvatore-orlando gravatar image

Hi Zak,

this is unfortunately the way nova works. If you're using security groups, then you need a subnet, otherwise nova will raise when booting a VM. If not, you can try and boot the VM passing a pre-created neutron port with:

nova boot .... --nic port-id=<neutron_port_id>

If that does not work either we'll see whether it is worth opening a bug for allowing this use case.

edit flag offensive delete link more
0

answered 2013-07-31 15:39:17 -0500

zestrada gravatar image

Unfortunately, when I create a a port on a network with no subnet/IP associated with it, no network device is created on the instance. Namely, "ifconfig -a" only returns the loopback device. After allocating a subnet, nova will plumb a network device.

It seems like this is how nova works, as you've pointed out. Should I reopen this as a bug?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-22 19:50:54 -0500

Seen: 90 times

Last updated: Jul 31 '13