Ask Your Question
0

Use Linux bridge to assign networks, but not IPs

asked 2013-05-22 19:50:54 -0500

zestrada gravatar image

I have setup quantum with the linux bridge plugin. For now, I'm not looking to do IPAM in quantum, just to create networks. I want to assign VMs to networks without IP subnets, but if i do that then nova doesn't create network interfaces for those VMs (no errors in either compute.log or linuxbridge-agent.log).

Here's an example:

[root@cloud1 ~(keystone_admin)]# quantum net-create lab-test --tenant_id 60899984662e4f38b703f7126de48473 --provider:network_type flat --provider:physical_network testnet Created a new network: +---------------------------+--------------------------------------+ | Field | Value | +---------------------------+--------------------------------------+ | admin_state_up | True | | id | 29989e92-3210-4d7c-af1b-dba53165352b | | name | lab-test | | provider:network_type | flat | | provider:physical_network | testnet | | provider:segmentation_id | | | router:external | False | | shared | False | | status | ACTIVE | | subnets | | | tenant_id | 60899984662e4f38b703f7126de48473 |

+---------------------------+--------------------------------------+


[root@cloud1 ~(keystone_user)]$ nova boot --flavor m1.small --image rh6 --nic net-id=29989e92-3210-4d7c-af1b-dba53165352b test

testnet does exist in the plugin.ini:

network_vlan_ranges = testnet:100:200 ...

physical_interface_mappings = testnet:vbr-em1

Inside the vm, I only have the "lo" interface. If I create a subnet, then an eth0 device gets created. I've tried both "flat" and "vlan" for network_type.

What's the right way to do this?

Thanks!

edit retag flag offensive close merge delete

16 answers

Sort by ยป oldest newest most voted
0

answered 2013-06-12 09:07:20 -0500

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

edit flag offensive delete link more
0

answered 2013-05-24 09:52:14 -0500

gongysh gravatar image

create a subnet and then boot instance.

edit flag offensive delete link more
0

answered 2013-05-27 16:36:23 -0500

zestrada gravatar image

I suppose one thing that might make this question more clear is to specify that I'm only trying to use quantum for L2 networking (i.e. creating tagged VLANs) and not for managing L3 subnets/addresses/etc. Is this possible?

edit flag offensive delete link more
0

answered 2013-05-24 14:04:12 -0500

zestrada gravatar image

If I create a subnet, that requires specifying a CIDR and it assigns an IP to the instance. While I don't have DHCP enabled, quantum still appears to do IPAM.

Thanks! On May 24, 2013 5:03 AM, "yong sheng gong" < question229425@answers.launchpad.net > wrote:

Your question #229425 on quantum changed: https://answers.launchpad.net/quantum/+question/229425 (https://answers.launchpad.net/quantum...)

Status: Open => Answered

yong sheng gong proposed the following answer: create a subnet and then boot instance.


If this answers your question, please go to the following page to let us know that it is solved: https://answers.launchpad.net/quantum/+question/229425/+confirm?answer_id=0 (https://answers.launchpad.net/quantum...)

If you still need help, you can reply to this email or go to the following page to enter your feedback: https://answers.launchpad.net/quantum/+question/229425 (https://answers.launchpad.net/quantum...)

You received this question notification because you asked the question.

edit flag offensive delete link more
0

answered 2013-07-31 15:45:09 -0500

salvatore-orlando gravatar image

I think you can either ask the saame question in nova - or transform this in a bug, targeting both nova and neutron (even if I think no change might be required on the neutron side).

This will probably get some nova developers too in the discussion.

edit flag offensive delete link more
0

answered 2013-07-31 09:28:24 -0500

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

edit flag offensive delete link more
0

answered 2013-07-15 12:23:38 -0500

zestrada gravatar image

That does work, but then I'm 'assigning' an IP in neutron (even though I'm not using it).

Thanks! --Zak On Jul 14, 2013 6:21 PM, "Edgar Magana" < question229425@answers.launchpad.net > wrote:

Your question #229425 on neutron changed: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

Status: Open => Answered

Edgar Magana proposed the following answer: Did you try creating network and subnet with NO DHCP? You can do the following: quantum subnet-create network-name 192.168.0.0/24 --enable_dhcp False


If this answers your question, please go to the following page to let us know that it is solved: https://answers.launchpad.net/neutron/+question/229425/+confirm?answer_id=9 (https://answers.launchpad.net/neutron...)

If you still need help, you can reply to this email or go to the following page to enter your feedback: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

You received this question notification because you asked the question.

edit flag offensive delete link more
0

answered 2013-06-12 14:05:46 -0500

zestrada gravatar image

This issue still exists, closed by janitor so I'm commenting to reopen. On Jun 12, 2013 4:18 AM, "Launchpad Janitor" < question229425@answers.launchpad.net > wrote:

Your question #229425 on quantum changed: https://answers.launchpad.net/quantum/+question/229425 (https://answers.launchpad.net/quantum...)

Status: Open => Expired

Launchpad Janitor expired the question: This question was expired because it remained in the 'Open' state without activity for the last 15 days.


If you're still having this problem, you can reopen your question either by replying to this email or by going to the following page and entering more information about your problem: https://answers.launchpad.net/quantum/+question/229425 (https://answers.launchpad.net/quantum...)

You received this question notification because you asked the question.

edit flag offensive delete link more
0

answered 2013-06-28 09:12:55 -0500

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

edit flag offensive delete link more
0

answered 2013-06-28 13:22:29 -0500

zestrada gravatar image

This issue still stands. I can manage L2 VLANs fine with quantum, but not without assigning a subnet/IP. It makes things confusing, especially if I have separate networks that will actually get IPs from quantum. On Jun 28, 2013 5:16 AM, "Launchpad Janitor" < question229425@answers.launchpad.net > wrote:

Your question #229425 on neutron changed: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

Status: Open => Expired

Launchpad Janitor expired the question: This question was expired because it remained in the 'Open' state without activity for the last 15 days.


If you're still having this problem, you can reopen your question either by replying to this email or by going to the following page and entering more information about your problem: https://answers.launchpad.net/neutron/+question/229425 (https://answers.launchpad.net/neutron...)

You received this question notification because you asked the question.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-22 19:50:54 -0500

Seen: 480 times

Last updated: Jul 31 '13