Ask Your Question
0

nova-network never start can't start instance

asked 2012-06-20 14:25:16 -0500

ronan-lanore gravatar image

Hi,

I have got essex source from github and when start nova-network it never start. I can't start a instance beacause of that.

error when start instance : http://paste.openstack.org/show/18650/

To launch nova-network i do:

sudo ./bin/nova-network --flagfile=./etc/nova/nova.conf --debug

patesbin output : http://paste.openstack.org/show/18648/

To verify service is realy started i do :

sudo nova-manage service list

Binary Host Zone Status State Updated_At nova-compute troy nova enabled XXX 2012-06-20 12:19:32 nova-scheduler troy nova enabled XXX 2012-06-20 12:19:33 nova-consoleauth troy nova enabled XXX 2012-06-19 13:35:02 nova-network troy nova enabled XXX 2012-06-19 13:35:02 nova-cert troy nova enabled XXX 2012-06-20 12:19:33 nova-console troy nova enabled XXX 2012-06-19 13:35:02 nova-volume troy nova enabled XXX 2012-06-20 12:19:33

when i use noval-all to launch all sevice nova-network still in error state

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-06-20 20:38:54 -0500

vishvananda gravatar image

looks like you have a stale lockfile. Try deleting nova-iptables.lock in your source directory and then starting nova-network.

edit flag offensive delete link more
0

answered 2012-06-20 21:20:10 -0500

ronan-lanore gravatar image

Problem solved. Thanks a lot

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-06-20 14:25:16 -0500

Seen: 53 times

Last updated: Jun 20 '12