Ask Your Question
0

Account and User creation failed

asked 2011-04-26 02:23:12 -0500

everett-toews gravatar image

Hi All,

When I try to create a user using the .super_admin credentials I get an error.

root@i-00000c7f:~# swauth-add-user -A https://127.0.0.1:8080/auth/ -U .super_admin -K mykey test-account test-user test-passwd Account creation failed: 400 Bad Request User creation failed: 400 Bad Request

I know the .super_admin is working to some degree because I can run the following.

root@i-00000c7f:~# swauth-list -A https://127.0.0.1:8080/auth/ -U .super_admin -K mykey {"accounts": [{"name": "system"}]}

I haven't been able to find any useful errors in syslog on the proxy or nodes but I'm open to suggestions as to what to look for.

In proxy-server.conf

allow_account_management = true

Any ideas what might be wrong?

Thanks, Everett

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2011-04-27 19:45:00 -0500

everett-toews gravatar image

Apparently account and usernames cannot contain hyphens. This works:

swauth-add-user -A https://127.0.0.1:8080/auth/ -U .super_admin -K mykey testaccount testuser testpasswd

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-04-26 02:23:12 -0500

Seen: 15 times

Last updated: Apr 27 '11