Ask Your Question
0

VMs get DHCP server's address as a default gateway

asked 2013-04-19 17:32:12 -0500

a-s-o-anas gravatar image

I'm getting a weird behaviour. When I run a VM, it gets the address of DHCP server (dnsmasq) as the default gateway !!!! My install is as follow : - two physical nodes, each with two NICs (one for management network, and the other for Data network (VMs) ) - OS : CentOS 6.4 - L2 plugin : Linuxbridge - namespaces=False - dhcp-agent is running on the controller node (all openstack services : nova, glance, cinder, quantum-server, ...) - l3-agent is runnig on the compute node Because of the misconfigured gateway, I can't access to my VMs using floating IPs, till I change the default gateway myself(I can access the VMs using their fixed IPs) any idea what's wrong? if you need any additional information, you can ask. thanks in advance

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2013-04-19 17:32:58 -0500

a-s-o-anas gravatar image

I wanna add that I'm using Folsom

edit flag offensive delete link more
0

answered 2013-04-19 18:32:19 -0500

danwent gravatar image

yeah, i've seen this before.

My understand is that this happens on redhat/centos versions that have a version of dnsmasq that is older than what quantum is expecting. basically, the config we push to dnsmasq is not interpreted correctly, meaning dnsmasq does its default behavior of using its own IP as the gateway. i'll convert this to a bug, as we should either check the dnsmasq version and push the right config, or document the version requirements around dnsmasq better.

On Fri, Apr 19, 2013 at 10:35 AM, AnasASO < question227068@answers.launchpad.net > wrote:

New question #227068 on quantum: https://answers.launchpad.net/quantum/+question/227068 (https://answers.launchpad.net/quantum...)

I'm getting a weird behaviour. When I run a VM, it gets the address of DHCP server (dnsmasq) as the default gateway !!!! My install is as follow : - two physical nodes, each with two NICs (one for management network, and the other for Data network (VMs) ) - OS : CentOS 6.4 - L2 plugin : Linuxbridge - namespaces=False - dhcp-agent is running on the controller node (all openstack services : nova, glance, cinder, quantum-server, ...) - l3-agent is runnig on the compute node Because of the misconfigured gateway, I can't access to my VMs using floating IPs, till I change the default gateway myself(I can access the VMs using their fixed IPs) any idea what's wrong? if you need any additional information, you can ask. thanks in advance


You received this question notification because you are an answer contact for quantum.


~~~~~~~~~~~~~~~~~~~~~~~~~~~ Dan Wendlandt Nicira, Inc: http://www.nicira.com twitter: danwendlandt ~~~~~~~~~~~~~~~~~~~~~~~~~~~

edit flag offensive delete link more
0

answered 2013-04-19 18:45:31 -0500

a-s-o-anas gravatar image

thanks dan for your reply my version of dnsmasq is 2.48, and it is the latest version available for redhat distributions.

edit flag offensive delete link more
0

answered 2013-04-20 11:09:35 -0500

a-s-o-anas gravatar image

Hi everyone, I've solved this problem by updating dnsmasq. The version available using "yum install ..." is 2.48, and it is the latest one available. So, I had to look for a new version somewhere else. Here is where I found a new version than the one available : http://rpm.pbone.net/index.php3/stat/4/idpl/20656900/dir/redhat_el_6/com/dnsmasq-2.65-1.el6.rfx.x86_64.rpm.html (http://rpm.pbone.net/index.php3/stat/...) and this is an other link : http://www.mediafire.com/download.php?djqxz6lqa21hid6 (http://www.mediafire.com/download.php...) thanks dan for the hint ;)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-19 17:32:12 -0500

Seen: 506 times

Last updated: Apr 20 '13