Ask Your Question

swift auth always returns as host IP

asked 2011-07-25 07:26:29 -0500

I have updated the rings files with the correct IP changed any where I found to the correct IP flushed memcache, set all servers bind_ip to NOT I even "less" the ring files to see if the IP in there is good.

but I still I get as the storage -url

I am trying to run "swift" from remote machine

where is the "storage_url" generated and stored? does memcached write files anywhere that I am not clearing? memcflush --servers=

HTTP/1.1 200 OK < X-Storage-Url: < X-Storage-Token: AUTH_tkfdb0354962d74ecbb593670b8380a556 < X-Auth-Token: AUTH_tkfdb0354962d74ecbb593670b8380a556 < Content-Length: 0 < Date: Mon, 25 Jul 2011 07:00:38 GMT

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2011-07-25 14:45:47 -0500

btorch gravatar image

Hi SV savage,

-- tempauth -- If you are using tempauth for your authentication system (should only be used for testing purposes), then I believe you need to set the user in the proxy-server.conf file as shown below:

user_<account>_<user> = <key> [group] [storage_url]

Once the above is done, restart proxy-server

-- swauth -- If you are using swauth ( ), then you would need to specify the "default_swift_cluster" option in the proxy-server.conf within the [filter:swauth] section.

Example: default_swift_cluster = locals#https://PUBLIC_IP:PORT/v1#

Once the above is done, restart proxy-server

Also, in the case of swauth, you could either create a new user which will then have the new storageUrl. Or you could use the swauth-set-account-service tool the modify the current user storage url.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2011-07-25 07:26:29 -0500

Seen: 107 times

Last updated: Jul 25 '11