Ask Your Question
0

swift-auth 405 and 503 errors

asked 2011-01-07 00:03:02 -0500

sonali2197 gravatar image

When I try to execute this command, i get "Update failed: 503 Service Unavaialable" error

swift-auth-add-user -K devauth -a system root testpass

I changed the following in the conf files:

account-server.conf: [DEFAULT] mount_check =false

proxy-server.conf: [DEFAULT] bind_port = 8080

I've used revision 154. The syslog shows the following errors

Jan 6 18:50:38 ubuntu-x3850-2 auth-server validate_token('AUTH_tkf6b99764fe994deaad50287a69da0d6e', _, _) = (86399.985820055008, '.super_admin', '.single_use', '.reseller_admin') [0.00] Jan 6 18:50:38 ubuntu-x3850-2 auth-server 127.0.0.1 - - [06/Jan/2011:23:50:38 +0000] "GET /token/AUTH_tkf6b99764fe994deaad50287a69da0d6e HTTP/1.0" 204 - "-" "-" - - - - - - - - - "-" "127.0.0.1" "-" 0.0036 Jan 6 18:50:38 ubuntu-x3850-2 auth-server ERROR attempting to create account http://127.0.0.1:8080/v1/AUTH_72c5c27b93c048b2930a8df3379e012c (http://127.0.0.1:8080/v1/AUTH_72c5c27...) : 405 Method Not Allowed Jan 6 18:50:38 ubuntu-x3850-2 auth-server FAILED create_user('test', 'tester', _, True, False) [0.03] Jan 6 18:50:38 ubuntu-x3850-2 proxy-server - 127.0.0.1 06/Jan/2011/23/50/38 PUT /v1/AUTH_72c5c27b93c048b2930a8df3379e012c HTTP/1.0 405 - - .super_admin%3A.single_use%2CAUTH_tkf6b99764fe994deaad50287a69da0d6e - - - tx9937af5a-4eb1-41ec-b849-635e322b8f6b - 0.0021 Jan 6 18:50:38 ubuntu-x3850-2 auth-server 127.0.0.1 - - [06/Jan/2011:23:50:38 +0000] "PUT /account/test/tester HTTP/1.0" 503 - "-" "-" - - - - - - - - - "-" "127.0.0.1" "-" 0.0288

Any ideas on how to fix this? Thanks!

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2011-01-07 15:35:43 -0500

gholt gravatar image

Quite likely you need to add allow_account_management = true to your proxy configuration.

Here's a bit more of an explanation from the mailing list:

https://lists.launchpad.net/openstack/msg00096.html (https://lists.launchpad.net/openstack...)

edit flag offensive delete link more
0

answered 2011-01-07 23:54:05 -0500

sonali2197 gravatar image

Thanks gholt, that solved my question.

edit flag offensive delete link more
0

answered 2011-01-07 23:55:18 -0500

sonali2197 gravatar image

In addition to that I had to change the permissions for the partitions

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-01-07 00:03:02 -0500

Seen: 246 times

Last updated: Jan 07 '11