Cloudpipe instance network configuration

asked 2011-04-18 16:06:50 -0600

ethuleau gravatar image

How a cloudpipe instance gets the first IP of subnet project ?

I made a cloudpipe template with following the doc ( http://nova.openstack.org/devref/cloudpipe.html (http://nova.openstack.org/devref/clou...) ). When I start it with command 'nova-manage vpn run PROJECT_ID', the instance starts correctly but it doesn't take the first IP of the subnet.

edit retag flag offensive close merge delete

7 answers

Sort by ยป oldest newest most voted
0

answered 2011-04-26 13:35:11 -0600

ethuleau gravatar image

Ok the fix works for me too.

Thanks.

edit flag offensive delete link more
0

answered 2011-04-18 16:56:10 -0600

vishvananda gravatar image

This is probably a bit unclear, but the flag:

--vpn_image_id

needs to be set to the numeric id of the image instead of the ami. This is due to recent changes in the handling of images. You can manually convert an ami id back to the numeric id with something like this:

let x=0x449256c4; echo $x

which will give you the numeric version of ami-449256c4

Vish

On Apr 18, 2011, at 9:06 AM, Edouard Thuleau wrote:

New question #153304 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+q...

How a cloudpipe instance gets the first IP of subnet project ?

I made a cloudpipe template with following the doc ( http://nova.openstack.org/devref/clou... ). When I start it with command 'nova-manage vpn run PROJECT_ID', the instance starts correctly but it doesn't take the first IP of the subnet.


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-04-19 08:31:28 -0600

ethuleau gravatar image

I tried to use the numeric ID of the image :

$ euca-describe-images IMAGE aki-00000031 None (cloudpipe-kernel) available public kernel IMAGE ami-00000032 None (cloudpipe) available public machine aki-00000031

When I set the numeric value (50) to the flag --vpn_image_id, nova-manage got the error 'NotFound: Image 50 not found'. When I set the AMI ID (ami-00000032) to the flag --vpn_image_id, nova-manage can launch the cloudpipe image but the instance doesn't get the first IP of the subnrt project.

I use the bzr1003 on Ubuntu 10.04 LTS.

edit flag offensive delete link more
0

answered 2011-04-19 14:30:39 -0600

vishvananda gravatar image

aha. Yes this looks like a bug. nova-manage expects the ami when launching but nova-network expects the numeric id. We need to change one of them to convert. I'll work on a patch

Vish

On Apr 19, 2011, at 1:31 AM, Edouard Thuleau wrote:

Question #153304 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Open

Edouard Thuleau is still having a problem: I tried to use the numeric ID of the image :

$ euca-describe-images IMAGE aki-00000031 None (cloudpipe-kernel) available public kernel IMAGE ami-00000032 None (cloudpipe) available public machine aki-00000031

When I set the numeric value (50) to the flag --vpn_image_id, nova-manage got the error 'NotFound: Image 50 not found'. When I set the AMI ID (ami-00000032) to the flag --vpn_image_id, nova-manage can launch the cloudpipe image but the instance doesn't get the first IP of the subnrt project.

I use the bzr1003 on Ubuntu 10.04 LTS.


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-04-19 14:44:32 -0600

ethuleau gravatar image

Ok, thanks.

In the sample OpenVPN configuration gives in doc ( http://bazaar.launchpad.net/~hudson-openstack/nova/trunk/view/head:/doc/source/devref/cloudpipe.rst (http://bazaar.launchpad.net/~hudson-o...) ), the OpenVPN server use bridge mode and the bridge 'br0' is define.

Do I need to set up this bridge in the template ? If yes, I need to add the VNIC (eth0) in this bridge ? And set a dhclient on this VNIC (eth0) or on the bridge (br0) ?

edit flag offensive delete link more
0

answered 2011-04-19 16:30:21 -0600

vishvananda gravatar image

I added instructions on network interface to the docs in my bugfix branch here:

https://code.launchpad.net/~vishvanan...

I'm verifying that the fix there actually works now.

On Apr 19, 2011, at 7:44 AM, Edouard Thuleau wrote:

Question #153304 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Open

Edouard Thuleau is still having a problem: Ok, thanks.

In the sample OpenVPN configuration gives in doc ( http://bazaar.launchpad.net/~hudson- openstack/nova/trunk/view/head:/doc/source/devref/cloudpipe.rst), the OpenVPN server use bridge mode and the bridge 'br0' is define.

Do I need to set up this bridge in the template ? If yes, I need to add the VNIC (eth0) in this bridge ? And set a dhclient on this VNIC (eth0) or on the bridge (br0) ?


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-04-19 18:26:51 -0600

vishvananda gravatar image

Ok fix works for me. Feel free to test.

Vish

On Apr 19, 2011, at 9:30 AM, Vish Ishaya wrote:

Question #153304 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Open => Answered

Vish Ishaya proposed the following answer: I added instructions on network interface to the docs in my bugfix branch here:

https://code.launchpad.net/~vishvanan...

I'm verifying that the fix there actually works now.

On Apr 19, 2011, at 7:44 AM, Edouard Thuleau wrote:

Question #153304 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Open

Edouard Thuleau is still having a problem: Ok, thanks.

In the sample OpenVPN configuration gives in doc ( http://bazaar.launchpad.net/~hudson- openstack/nova/trunk/view/head:/doc/source/devref/cloudpipe.rst), the OpenVPN server use bridge mode and the bridge 'br0' is define.

Do I need to set up this bridge in the template ? If yes, I need to add the VNIC (eth0) in this bridge ? And set a dhclient on this VNIC (eth0) or on the bridge (br0) ?


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-04-18 16:06:50 -0600

Seen: 113 times

Last updated: Apr 26 '11