publish tarball Invalid certfailed to upload kernel

asked 2011-03-06 15:47:21 -0500

What have i done wrong? http://pastebin.com/e7YuM0Gf

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2011-03-07 06:01:31 -0500

cert files were not in the correct location. Once moved to the correct paths listed in the various variables (via export) everything worked.

edit flag offensive delete link more
0

answered 2011-05-09 03:19:27 -0500

rohitk gravatar image

Jason, can you please explain what you did to make it work? I see something related to the 'NOVA_KEY_DIR=$(pushd $(dirname $BASH_SOURCE)>/dev/null; pwd; popd>/dev/null) ' environment variable not getting correcrtly set. Hence the certs folder is not set in 'NOVA_CERT=${NOVA_KEY_DIR}/cacert.pem'

What value does the NOVA_KEY_DIR usually take?. My packaged installation of nova is in /var/lib/nova. Some of the workarounds I tried was copying the .pem files from ~/creds to /var/lib/nova/CA/certs , /var/lib/nova/CA/newcerts.

I am still seeing the exact same error that you encountered, and I'm using the tty-linux Ubuntu image.

edit flag offensive delete link more
0

answered 2011-05-09 06:11:25 -0500

vishvananda gravatar image

it should be the directory where you extracted the pem files and the novarc. That magic line is supposed to set the key dir to the directory that the novarc is in.

Vish

On May 8, 2011, at 8:20 PM, Rohit Karajgi wrote:

Question #148069 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Rohit Karajgi posted a new comment: Jason, can you please explain what you did to make it work? I see something related to the 'NOVA_KEY_DIR=$(pushd $(dirname $BASH_SOURCE)>/dev/null; pwd; popd>/dev/null) ' environment variable not getting correcrtly set. Hence the certs folder is not set in 'NOVA_CERT=${NOVA_KEY_DIR}/cacert.pem'

What value does the NOVA_KEY_DIR usually take?. My packaged installation of nova is in /var/lib/nova. Some of the workarounds I tried was copying the .pem files from ~/creds to /var/lib/nova/CA/certs , /var/lib/nova/CA/newcerts.

I am still seeing the exact same error that you encountered, and I'm using the tty-linux Ubuntu image.


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-05-13 22:05:08 -0500

Modifying ~/.bashrc to "NOVA_KEY_DIR=/root/creds/" fixed it for me.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-03-06 15:47:21 -0500

Seen: 43 times

Last updated: May 13 '11