Ask Your Question
0

configuring FlatManager & injecting IP address

asked 2011-12-29 09:27:20 -0500

I'm trying to setup FlatManager network, below is the nova.conf file...

--dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --flagfile=/etc/nova/nova-compute.conf --force_dhcp_release=True --use_deprecated_auth --verbose --s3_host=127.0.0.1 --rabbit_host=127.0.0.1 --cc_host=127.0.0.1 --ec2_url=http://127.0.0.1:8773/services/Cloud --fixed_range=10.0.0.0/24 --network_size=255 --FAKE_subdomain=ec2 --routing_source_ip=10.0.0.2 --verbose --sql_connection=mysql://root:xxxx@127.0.0.1/nova --network_manager=nova.network.manager.FlatManager --flat_interface=eth1 --public_interface=eth0 --flat_network_bridge=br100 --network_host=127.0.0.1 --connection_type=vmwareapi --vmwareapi_host_ip=10.0.0.2 --vmwareapi_host_username=root --vmwareapi_host_password=xxxxxxxxx --vmwareapi_wsdl_loc=http://127.0.0.1:8080/wsdl/vim25/vimService.wsdl --glance_api_servers=127.0.0.1:9292 --image_service=nova.image.glance.GlanceImageService --iscsi_ip_prefix=10.0.

i'm using ubuntu 11.04 natty server with diablo.

image file is VMDK file.

my problem is that IP address is not getting injected into created instance.. please help to solve this issue.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2011-12-29 10:02:55 -0500

By default, the flag flat_injected is False. Hence injection doesn't happen.

Can you add the flag --flat_injected=True to configuration file and try?

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-12-29 09:27:20 -0500

Seen: 44 times

Last updated: Dec 29 '11