Ask Your Question
0

Nova compute install problem on ubuntu: you have held broken packages.

asked 2012-10-02 16:47:19 -0500

krishna-sunitha gravatar image

Trying to follows steps from the following URL and below errors. Appreciate any alternative folsom install pointers. http://docs.openstack.org/trunk/openstack-compute/install/apt/content/installing-the-cloud-controller.html (http://docs.openstack.org/trunk/opens...)

root@ubuntu:~# apt-get -y install nova-common nova-compute nova-volume nova-vncproxy nova-api nova-ajax-console-proxy nova-cert nova-consoleauth nova-doc nova-scheduler nova-network Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: nova-vncproxy : Depends: nova-common (= 2012.2+git201209200431~precise-0ubuntu1) but 2012.2+git201209250431~precise-0ubuntu1 is to be installed E: Unable to correct problems, you have held broken packages. root@ubuntu:~#

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2012-10-04 23:42:09 -0500

krishna-sunitha gravatar image

Thanks John Garbutt, that solved my question.

edit flag offensive delete link more
0

answered 2018-09-03 08:58:05 -0500

Aref gravatar image

I have the same problem, here is my output:

root@devtest:~# apt install nova-api nova-conductor nova-consoleauth nova-novncproxy nova-scheduler nova-placement-api
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nova-consoleauth : Depends: nova-common (= 2:17.0.1-0ubuntu1) but 2:17.0.5-0ubuntu1 is to be installed
 nova-novncproxy : Depends: nova-common (= 2:17.0.1-0ubuntu1) but 2:17.0.5-0ubuntu1 is to be installed
 nova-placement-api : Depends: nova-common (= 2:17.0.1-0ubuntu1) but 2:17.0.5-0ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
edit flag offensive delete link more
0

answered 2012-10-04 11:44:27 -0500

msekni gravatar image

I am experiencing the same problem, if you find a solution please let me know !

edit flag offensive delete link more
0

answered 2012-10-04 13:37:41 -0500

johngarbutt gravatar image

It seems you should: "replace nova-vncproxy with nova-novncproxy"

See the email thread here: https://lists.launchpad.net/openstack/msg17186.html (https://lists.launchpad.net/openstack...)

I hope that helps!

edit flag offensive delete link more
0

answered 2012-10-04 23:42:43 -0500

krishna-sunitha gravatar image

Thanks much John!

root@ubuntu:~# sudo apt-get --force-yes install nova-common nova-compute nova-volume nova-novncproxy nova-api nova-ajax-console-proxy nova-cert nova-consoleauth nova-doc nova-scheduler nova-network

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-10-02 16:47:19 -0500

Seen: 375 times

Last updated: Sep 03 '18