Ask Your Question
0

command :"startmain"

asked 2011-03-21 01:58:05 -0500

shihangwei gravatar image

when i run "startmain" "Unable to locate config file for main-server. /etc/swift/main-server.conf does not exist?" but i cannot find this config in this link : http://swift.openstack.org/development_saio.html (http://swift.openstack.org/developmen...) help,thx .

edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2011-04-28 08:15:55 -0500

moubarik-siham gravatar image

thank you for your answer

edit flag offensive delete link more
0

answered 2011-04-27 16:17:05 -0500

david-goetz gravatar image

Looks like in your pipeline in /etc/swift/proxy-server.conf you have "wauth" instead of "swauth"

edit flag offensive delete link more
0

answered 2011-04-27 09:20:53 -0500

moubarik-siham gravatar image

When I run I startmain these errors appear even, I change the file startmain :

root@ubuntu:~/bin# startmain Starting proxy-server...(/etc/swift/proxy-server.conf) Traceback (most recent call last): File "/usr/local/bin/swift-proxy-server", line 7, in <module> execfile(__file__) File "/root/swift/trunk/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, *options) File "/root/swift/trunk/swift/common/wsgi.py", line 122, in run_wsgi loadapp('config:%s' % conf_file, global_conf={'log_name': log_name}) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 204, in loadapp return loadobj(APP, uri, name=name, *kw) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 224, in loadobj global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 278, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 405, in get_context global_additions=global_additions) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 503, in _pipeline_app_context for name in pipeline[:-1]] File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 409, in get_context section) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 431, in _context_from_use object_type, name=use, global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 361, in get_context global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 285, in _loadegg return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 561, in get_context object_type, name=name) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 600, in find_egg_entry_point for prot in protocol_options] or '(no entry points)')))) LookupError: Entry point 'wauth' not found in egg 'swift' (dir: /root/swift/trunk; protocols: paste.filter_factory, paste.filter_app_factory; entry_points: )

help, please tks

edit flag offensive delete link more
0

answered 2011-04-27 09:20:50 -0500

moubarik-siham gravatar image

When I run I startmain these errors appear even, I change the file startmain :

root@ubuntu:~/bin# startmain Starting proxy-server...(/etc/swift/proxy-server.conf) Traceback (most recent call last): File "/usr/local/bin/swift-proxy-server", line 7, in <module> execfile(__file__) File "/root/swift/trunk/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, *options) File "/root/swift/trunk/swift/common/wsgi.py", line 122, in run_wsgi loadapp('config:%s' % conf_file, global_conf={'log_name': log_name}) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 204, in loadapp return loadobj(APP, uri, name=name, *kw) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 224, in loadobj global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 278, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 405, in get_context global_additions=global_additions) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 503, in _pipeline_app_context for name in pipeline[:-1]] File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 409, in get_context section) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 431, in _context_from_use object_type, name=use, global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 361, in get_context global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 285, in _loadegg return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 561, in get_context object_type, name=name) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 600, in find_egg_entry_point for prot in protocol_options] or '(no entry points)')))) LookupError: Entry point 'wauth' not found in egg 'swift' (dir: /root/swift/trunk; protocols: paste.filter_factory, paste.filter_app_factory; entry_points: )

help, please tks

edit flag offensive delete link more
0

answered 2011-03-22 01:33:38 -0500

shihangwei gravatar image

okay,i am trying it .thx clayg

edit flag offensive delete link more
0

answered 2011-03-21 14:38:26 -0500

clay-gerrard gravatar image

My guess is your running the 1.2 release.

The docs for 1.3 expect the new version of swift-init.

The docs for 1.2 are here: http://swift.openstack.org/1.2/

Specifically your startmain script should look like this: #!/bin/bash

swift-init proxy-server start swift-init account-server start swift-init container-server start swift-init object-server start

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-03-21 01:58:05 -0500

Seen: 19 times

Last updated: Apr 28 '11