Ask Your Question
0

Enable 1Gb interface on KVM with nova-compute

asked 2011-08-07 23:50:05 -0600

cloudbuilders-n gravatar image

Hi everyone, we are running Varnish Cache over kvm in our nova cluster. The thing is, the performance is aufull, so ... we've realized that all instances booted with nova-compute on any node, are booted with 100Mb RTL interfaces, en we are seeing this line in libvirt.xml for any instance :

    <interface type='bridge'>
        <source bridge='br100'/>
        <mac address='02:16:3e:5a:ba:6f'/>
        <!--   <model type='virtio'/>  CANT RUN virtio network right now -->    <-- THIS LINE
        <filterref filter="nova-instance-instance-000000bf-02163e5aba6f">
            <parameter name="IP" value="172.16.144.24" />
            <parameter name="DHCPSERVER" value="172.16.144.1" />
        </filterref>
    </interface>

So, how to we enable virtio model or e1000 model for a performance boost on nova using kvm ?? We are really needing to enable this.

Thanks !!

edit retag flag offensive close merge delete

15 answers

Sort by » oldest newest most voted
0

answered 2011-08-08 01:39:54 -0600

vishvananda gravatar image

Remove the comments around the line. There are issues with nova-volume and corrupt net and some older kernels. Specifically lucid and centos 5.5. If you are not using nova-volume or those guests you should be able to uncomment that line with no issues. On Aug 7, 2011 4:51 PM, "Mercadolibre CloudBuilders" < question167276@answers.launchpad.net > wrote:

New question #167276 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+q...

Hi everyone, we are running Varnish Cache over kvm in our nova cluster. The thing is, the performance is aufull, so ... we've realized that all instances booted with nova-compute on any node, are booted with 100Mb RTL interfaces, en we are seeing this line in libvirt.xml for any instance :

<interface type="bridge"> <source bridge="br100"/> <mac address="02:16:3e:5a:ba:6f"/> <-- THIS LINE <filterref filter="nova-instance-instance-000000bf-02163e5aba6f"> <parameter name="IP" value="172.16.144.24"/> <parameter name="DHCPSERVER" value="172.16.144.1"/> </filterref> </interface>

So, how to we enable virtio model or e1000 model for a performance boost on nova using kvm ?? We are really needing to enable this.

Thanks !!


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-08-08 05:57:32 -0600

cloudbuilders-n gravatar image

Hi vish!! We ve tried that, and ran euca-reboot-instances over that inatance with no result at all, we keep seeing the "-device rtl19........" and no virtio modification over the -net line.

The thing is, is enough to run euca-reboot-instances for those changes to take effect? And the other thing is, yes, we are running lucid as a guest with kernel 2.6.32-32, should we DEFINITELLY go for maverick?

Thnk again vish

edit flag offensive delete link more
0

answered 2011-08-08 13:04:35 -0600

blamar gravatar image

You're going to need to restart any and all nova-compute services after making the template change as currently templates are only read during service start-up. Does this still not work after changing the template, restarting nova-compute, and then calling run-instances?

edit flag offensive delete link more
0

answered 2011-08-08 16:34:45 -0600

vishvananda gravatar image

To change new instances, change the libvirt.xml template

To change running instances, change the libvirt.xml file in the instance's directory (/var/lib/nova/instances/instance-xxxx/), then: virsh destroy instance-xxx virsh undefine instance-xxx virsh define libvirt.xml virsh start instance-xxx

Lucid guests will be fine as long as you don't try to dynamically attach a volume to them. If you need attachable volumes you have to use maverick+

Vish

On Aug 7, 2011, at 11:01 PM, Mercadolibre CloudBuilders wrote:

Question #167276 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Open

Mercadolibre CloudBuilders is still having a problem: Hi vish!! We ve tried that, and ran euca-reboot-instances over that inatance with no result at all, we keep seeing the "-device rtl19........" and no virtio modification over the -net line.

The thing is, is enough to run euca-reboot-instances for those changes to take effect? And the other thing is, yes, we are running lucid as a guest with kernel 2.6.32-32, should we DEFINITELLY go for maverick?

Thnk again vish


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-08-09 22:07:26 -0600

vishvananda gravatar image

Promoted this to a FAQ FAQ #1734: “Why doesn't nova use virtio networking by default?”.

edit flag offensive delete link more
0

answered 2011-08-08 16:48:12 -0600

cloudbuilders-n gravatar image

Perfect Brian/Vish !!

I'll try that !! the thing is ... if i KNOW i will not be using nova-volume, can i touch the template from the nova-compute side, to make sure it allways create a new instance using virtio nic ?

Im not talking about the libvirt.xml inside each instance, but the template nova-compute uses for every new created instance.

Thanks for the quick response Vish !

edit flag offensive delete link more
0

answered 2011-08-08 16:53:49 -0600

vishvananda gravatar image

Absolutely, that is why it is a template file. It should be in virt/libvirt.xml.template

Vish

On Aug 8, 2011, at 9:51 AM, Mercadolibre CloudBuilders wrote:

Question #167276 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Answered => Open

Mercadolibre CloudBuilders is still having a problem: Perfect Brian/Vish !!

I'll try that !! the thing is ... if i KNOW i will not be using nova- volume, can i touch the template from the nova-compute side, to make sure it allways create a new instance using virtio nic ?

Im not talking about the libvirt.xml inside each instance, but the template nova-compute uses for every new created instance.

Thanks for the quick response Vish !


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more
0

answered 2011-08-08 17:00:10 -0600

cloudbuilders-n gravatar image

Thanks Vish Ishaya, that solved my question.

edit flag offensive delete link more
0

answered 2011-08-08 21:19:36 -0600

cloudbuilders-n gravatar image

Vish ... one last thing.

What about if i want to try e1000 ethernet model and not virtio, by touching on the template <model type="virtio"/> for <model type="e1000"/> will do the work ?

edit flag offensive delete link more
0

answered 2011-08-09 00:22:57 -0600

vishvananda gravatar image

Yes that will work. I don't think you will see a significant difference in performance though.

Vish

On Aug 8, 2011, at 2:21 PM, Mercadolibre CloudBuilders wrote:

Question #167276 on OpenStack Compute (nova) changed: https://answers.launchpad.net/nova/+q...

Status: Solved => Open

Mercadolibre CloudBuilders is still having a problem: Vish ... one last thing.

What about if i want to try e1000 ethernet model and not virtio, by touching on the template <model type="virtio"/> for <model type="e1000"/> will do the work ?


You received this question notification because you are a member of Nova Core, which is an answer contact for OpenStack Compute (nova).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-08-07 23:50:05 -0600

Seen: 165 times

Last updated: Oct 14 '11