Ask Your Question
0

VM don't get IP addresses

asked 2013-04-05 15:45:48 -0500

I am running folsom on xcp-xapi. I canlaunch VMs, but they won't start since they cannot receive an IP Address and I cannot figure out why. I am using bridge to control networking, and FLATDHCP(no quantum). dnsmasq is running properly , when capturing packets I can see DHCPDISCOVER sent by the booting VM and DHCP REPLY by the DomU , but the VM keeps sending DISCOVERs ....here is my nova.conf file:

[DEFAULT] xenapi_disable_agent = True firewall_driver=nova.virt.firewall.NoopFirewallDriver agent_resetnetwork_timeout=300 sr_matching_filter="default-sr:true" #firewall_driver = nova.virt.firewall.IptablesFirewallDriver flat_injected = False xenapi_connection_password = folsom xenapi_connection_username = root xenapi_connection_url = http://169.254.0.1 compute_driver = xenapi.XenAPIDriver glance_api_servers = 192.168.178.196:9292 image_service=nova.image.glance.GlanceImageService rabbit_password=folsom rabbit_host = localhost rpc_backend = nova.openstack.common.rpc.impl_kombu ec2_dmz_host = 192.168.178.196 vncserver_proxyclient_address = 169.254.0.1 vncserver_listen = 0.0.0.0 vnc_enabled = true xvpvncproxy_base_url = http://192.168.178.196:6081/console novncproxy_base_url = http://192.168.178.196:6080/vnc_auto.html (http://192.168.178.196:6080/vnc_auto....) flat_interface = eth1 flat_network_bridge = xapi0 #vlan_interface = eth1 public_interface = eth3 network_manager = nova.network.manager.FlatDHCPManager logdir=/var/log/nova send_arp_for_ha = True multi_host = True instances_path = /var/lib/nova/instances lock_path = /var/lock/nova state_path = /var/lib/nova #volume_api_class = nova.volume.cinder.API enabled_apis = ec2,osapi_compute,metadata instance_name_template = instance-%08x libvirt_cpu_mode = none #libvirt_type = qemu sql_connection=mysql://nova:folsom@192.168.178.196/nova?charset=utf8 my_ip = 192.168.178.196 osapi_compute_extension = nova.api.openstack.compute.contrib.standard_extensions s3_port = 3333 s3_host = 192.168.178.196 default_floating_pool = nova fixed_range = 10.0.0.0/24 #fixed_range = 192.168.178.100.0/24 force_dhcp_release = True dhcpbridge_flagfile = /etc/nova/nova.conf compute_scheduler_driver = nova.scheduler.filter_scheduler.FilterScheduler scheduler_driver = nova.scheduler.filter_scheduler.FilterScheduler rootwrap_config = /etc/nova/rootwrap.conf api_paste_config = /etc/nova/api-paste.ini allow_resize_to_same_host = True auth_strategy = keystone debug = True verbose = True ## #nova-api# cc_host=192.168.178.196 nova_url=http://192.168.178.196:8774/v1.1 keystone_ec2_url=http://192.168.178.196:5000/v2.0/ec2tokens metadata_host=192.168.178.196 metadata_listen=0.0.0.0 dhcpbridge=/usr/bin/nova-dhcpbridge [spice]

enabled = false html5proxy_base_url = http://192.168.178.196:6082/spice_auto.html (http://192.168.178.196:6082/spice_aut...)

Bridge configuration on DomU:

root@ofoloxcp:~# brctl show bridge name bridge id STP enabled interfaces virbr0 8000.000000000000 yes xapi0 8000.22f5aac9636a no eth1

interface configuration on DomU:

eth0 Link encap:Ethernet HWaddr 7a:67:f4:d8:d9:73 inet addr:169.254.0.3 Bcast:169.254.0.255 Mask:255.255.255.0 inet6 addr: fe80::7867:f4ff:fed8:d973/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:13319 errors:0 dropped:0 overruns:0 frame:0 TX packets:13313 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:7229340 (7.2 MB) TX bytes:1877134 (1.8 MB) Interrupt:25

eth1 Link encap:Ethernet HWaddr 22:f5:aa:c9:63:6a inet6 addr: fe80::20f5:aaff:fec9:636a/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:475 ... (more)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-04-11 10:25:51 -0500

solved my problem :D , Thank you SO MUCH :)

edit flag offensive delete link more
0

answered 2013-04-06 20:13:45 -0500

david-wittman gravatar image

I'm not sure if it even exists in the Xen world, but this sounds very similar to the vhost_net issue with KVM/libvirt. Check to see if you're using the vhost_net module and disable or add the appropriate iptables mangle rules if so.

https://bugs.launchpad.net/openstack-...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-05 15:45:48 -0500

Seen: 42 times

Last updated: Apr 11 '13