Ask Your Question
0

Issue with two Ethernet interfaces.

asked 2013-04-09 00:56:26 -0500

Q20 gravatar image

I have one dedicated server with two Ethernet interfaces (eth0, eth1), I have followed "All-In-One: Dedicated Hardware" OpenStack guide on many Linux versions so far.

eth0: is a private IP address (our official organization LAN IP address). eth1: is a temporary public IP (it is used to connect through git, since our organization proxy is firewalled and allows only port 8080). In the localrc file the "FLAT_INTERFACE=eth0".

After running ./stack.sh, I get the following: Horizon is now available at /my-public-ip/ Keystone is serving at /my-public-ip:5000/v2.0/ Examples on using novaclient command line is in exercise.sh The default users are: admin and demo The password: supersecret This is your host ip: my-public-ip stack.sh completed in 1283 seconds.

I have disabled eth1 (the one with temporary public IP) and rerun ./stack.sh, and I got the following: Horizon is now available at /127.0.0.1/ Keystone is serving at /127.0.0.1:5000/v2.0/ Examples on using novaclient command line is in exercise.sh The default users are: admin and demo The password: supersecret This is your host ip: 127.0.0.1 stack.sh completed in 110 seconds.

WHY ON EARTH those scripts are not binding to my private IP !!! Is there a workaround to manually do that.

Thank you in advance.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-04-11 05:30:35 -0500

sdague gravatar image

Devstack tries to detect the interface where your default route is, and use that. However if you have a working installation with only 1 interface for both management and guests, your management IP will have been migrated to the default bridge interface, and that detection can break down.

There is an override variable in your localrc called: HOST_IP. If you set that, all the services will come up on that IP explicitly.

edit flag offensive delete link more

Comments

Thank you Mr. sdague, that resolved my issue.

Q20 gravatar imageQ20 ( 2013-04-12 23:33:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-04-09 00:56:26 -0500

Seen: 130 times

Last updated: Apr 11 '13